Re: I've got a user32.dll error. What I can do?
Posted in 1999
Topics: Backup & Restore, Installation, Setup & Upgrades, Stored Procedures & SPL, Error Codes & Troubleshooting, Versions, Editions & End-of-Life
Thanks a lot. David.
I had readed that article on MS Website. The server is configured "desktop
heap" with the that instruction, but those don't fix nothing. That article
is big lie.
Well, I have to shutdonw the server every night, in fact, that clears the
memory and it resolves the problem.
But this problem gets worst since I had to install informix under server has
64 MB RAM. I'm getting user32.dll error every 2 or 3 hours. the worst is
when ontape thread is executed, the server doesn't have any resource of
memory to proccess informix's request and it gets PANIC error and instance
brings shutdonw.
some suggestion?
David McPaul wrote:
> I don't know if this is relevent but we used to get user32.dll failures
> on our NT box from stopping and starting a number of NT services each
> night. Eventually one service will refuse to start with user32.dll
> could not be initialised. Eventually we found the following at the MS
> website
>
> <QUOTE>
> How To Overcome USER32.DLL Initialization Failure Errors The following
> is an excerpt from Article ID: Q142676 from the Microsoft Knowledge Base
> accessible via the web. SYMPTOMS When your try to start a servie a
> pop-up dialog box appears with the following message: SERVICE_NAME -
> DLL Initialization failure Initialization of the dynamic link library
> c:\\winnt\\user32.dll failed. The process is terminating abnormally.
> CAUSE The system has run out of memory to create a new desktop heap for
> the service being started. (This is most commonly seen with
> FaxSr_Mailgate4 and sometimes seen upon system reboot). RESOLUTION
> Fixing this problem requires editing the registry and restarting the
> computer showing this system. (Please refer to Microsoft TechNet
> Knowledge Base for actually registry edit instructions). If you are
> unable to access this information contact Omtool Technical Support to
> have the information forwarded to you. STATUS Microsoft has confirmed
> this to be a problem in Windows NT 4.0. They are researching this
> problem and will post new information in the Microsoft Knowledge Base as
> it becomes available.
>
> 052 ' Out of Memory or user32.dll failure in Windows NT 4.0.
> If you get user32.dll failure when starting a service or out of memory
> errors when you have available memory, try this:
> HKEY_LOCAL_MACHINE\\System\\CurrentControlSet\\Control\\SessionManager\\SubSy
> stems\\Windows
> Scan for SharedSection=xxxx, yyyy where xxxx defines the maximum size of
> the system-wide heap (in kilobytes) and yyyy defines the size of the per
> desktop heap. Add ",zzzz" immediately after yyyy where zzzz is the size
> of the hidden desktop heap created by non-interactive processes. Setting
> this to 512 will often solve your problem. When you're done, this string
> will look like SharedSection=xxxx, yyyy, zzz.
> If you still get out of memory errors, increase yyyy by 256 until the
> application runs.
> You might also delete RegistrySizeLimit from
> HKEY_LOCAL_MACHINE\\System\\CurrentControlSet\\Control and setting
> PagePoolSize to 0 at
> HKEY_LOCAL_MACHINE\\System\\CurrentControlSet\\Control\\SessionManager\\Memor
> y Management.
> You will need to reboot.
> </QUOTE>
>
> What we basically figured from that is that stopping a service does not
> free all memory. The fix above just increases the amount of memory
> available. Eventually we reduced the need to stop/start services.
> However I suspect this will only alleviate the problem not fix it. The
> same problem is likely to occur and require a reboot. Some server OS
> huh!
>
> Cheers
> David
> Lumley Technology
> ++61 2 9248 1356
>
> > -----Original Message-----
> > From: Francisco Huezo [mailto:fhuezo@mh.gob.sv]
> > Sent: Wednesday, 24 March 1999 9:58
> > To: kagel@bloomberg.net; iiug
> > Subject: Re: I've got a user32.dll error. What I can do?
> >
> >
> > Hi.
> >
> > Thanks a lot.
> >
> > I tried it but it didn't work. The spaw space is 3 times to
> > physical memory,
> > otherwise, it's 386 MB and it's splited on 2 fragments. Also,
> > the server
> > instance uses minimized resource. It only has configured two segmects
> > memories, viruals has 9M and Resident has 8 M.
> >
> > another suggestion?
> >
> > "Art S. Kagel" wrote:
> >
> > > Francisco Huezo wrote:
> > > >
> > > > Hi. everybody.
> > > >
> > > > I have a serios problems with IDS 7.3 under NT 4. In the
> > server I have
> > > > to install NT w/SP 3, ArcServer, SMS, Norton Antivirus,
> > IDS 7.3. and
> > > > anothers importantless softwares
> > > >
> > > > The server has 128 MB in RAM with 2 Pentium Pro
> > Microprocessor. Well,
> > > > the problem is I can use the server about 48 hours,
> > after I get a
> > > > message box said:
> > > >
> > > > "onsmnp failt, memory out of resource, unable link
> > user32.dll library"
> > > >
> > > > Do somebody knows how I can fix this?
> > >
> > > I'm no Windows expert, don't even like the environment much, but it
> > > sounds to me like the windows swap file is too small. If
> > you made it
> > > dynamic it may be that adding some software has filled the
> > disk and is
> > > preventing the expansion of the swap file. Clear space, make it
> > > permanent, and/or increase its size.
> > >
> > > Art S. Kagel
> >
we had the same problem. informix gave the next solution: check if the informix user has the neccessary rights: start->programs->admin. tools->user manager (for domains) click on Policies->User Rights check the option advanced user rights and check the next rights act as part of the OS and Log on as a service. philippe