Re: Informix cannot start up properly
Posted in 1998
In article <memo.19981113120105.19891A@wfsoftware.compulink.co.uk>, WF
Software <paulw@wfsoftware.co.uk> writes
>In article <72av1o$mmn$1@mawar.singnet.com.sg>, joshuaho@singnet.com.sg
>(jh) wrote:
>
>> Hi,
>>
>> When I issue a oninit -s, it give an error message on the console :
>> 'oninit: forced-resident shared memory not available'. When I look
>> into the
>> message log, there is one line showing : 'Error: Unable to reset open
>> files
>> limit, must run as super-user'.
>>
Check that oninit is still setuid root.
Look in $INFORMIXDIR/etc/onlinefiles (??)
Certainly $INFORMIXDIR/etc/*files for the correct permissions...
>> I'm running ODS 7.22 on solaris 2.5.1.
>>
>There is something real odd 'cos resident memory is available and it
>should just work. The unable to reset open files is odd 'cos on a per
>process basis it's set to 64 by default, on a system level it should be
>full automatic based on your system.
>
>Are you sure the product as installed correctly?
>Is the kernel configured as per the release notes?
>
>Paul Watson # I don't suffer from
>WF Software Ltd. # stress, I'm just
>Tel. (+44) 1436 674729 # a carrier
>Fax. (+44) 1436 678693 #
>www.wfsoftware.co.uk
--
David Williams
Maintainer of the Informix FAQ
Primary site (Beta Version) http://www.smooth1.demon.co.uk
Official site http://www.iiug.org/techinfo/faq/faq_top.html
I see you standin', Standin' on your own, It's such a lonely place for you, For
you to be If you need a shoulder, Or if you need a friend, I'll be here
standing, Until the bitter end...
So don't chastise me Or think I, I mean you harm...
All I ever wanted Was for you To know that I care