RE: Informix and RAID
Posted in 2004
Martin Fuerderer wrote: > Another thing to consider is trusting only the statistics that > you've forged yourself, a point of view that often can be changed > only through an adverse life experience. And probably we should > not force any die-hards to miss such an opportunity for a > personality forming life experience ... ;-) BTW, I don't consider myself a die-hard proponent of RAID 5 (if that was implied). The comment I made about my (limited) experience with hard drive failures was simply an anecdote. Mitigating risk often costs money, and I like to understand what the risks and consequences are, and how much it costs to reduce those risks to an acceptable level. Another anecdote: I don't pay to extend the warranty coverage of household appliances; i.e. I sleep fine at night when I assume a reasonable amount of risk. Now, Art S. Kagel wrote: > Before I won the RAID war here, I used to spend one to three nights every > month rebuilding indexes overnight... That was a year or so before > the mass drive failure finally convinced the SAs and managers to switch to > RAID10... In the 5 years since..., none of the DBAs have gotten even > one of those calls due to disk or controller problems and we've only gotten > one corrupted index in all that time on all those servers. For me personally, this is stronger argument than telling me that I might experience two disk failures before the servers had time to rebuild a hot spare to replace the first one that failed. (Many things could take out enough disks to bring down a system. The question is, "What are the chances of those events happening, and what is your contingency plan if they do?") We do occasionally have to rebuild indexes. Even more noticeable to production managers are the assert failures that we encounter from time to time that are apparently associated with "bad pages" (7.31 UC2 x6, btw). Do I know that these bad indexes or assert failures are being caused by RAID 5? No. Am I willing to entertain the idea that they might be? Sure. One way to try to find out is to switch to RAID 10 and see what happens over time. Regarding controllers that support RAID 10, Colin B wrote: > This is definitely a case of the tail wagging the dog. > > It they only do RAID5 not RAID10, tell the salesman to FO and provide > the customer with what they want. > > It is a pity you do not work for a company with some clout. :-) I'm a tiny IT fish in a large ocean filled with sharks, many of whom wish we were running SQL Server on some OS other than Solaris. (Did I just say that?) and also on this subject, Art S. Kagel wrote: > Then you're purchasing your RAID controllers from the wrong vendors. Fair enough. If RAID 10 is important to you, then I would hope there is a vendor out there that builds a controller/driver that supports RAID 10 and is compatible with the hardware/software you have. The driver I was thinking about is the "HP Third Generation Array Controller" drivers for Solaris 8/9 for the controller that comes standard with the HP DL380 G3 server. Do let me know if I'm wrong about whether this driver supports RAID 10. As far as I could tell, it doesn't. Also, let me know what sort of low-cost external storage solutions are available for this platform - if you know. Have a nice weekend, John sending to informix-list