Invalid Pool Name error
Posted in 2019
Topics: Server Administration
Hi All, I posted a question previously about a "bad file number" error I was receiving when issuing this command, "ism_op -mount /backups/txlogs". I haven't had any luck resolving it. Today I decided to try a work around. I Dropped the device "ism_rm -device /backups/txlogs" and then tried to create it again "ism_add -device /backups/txlogs" and got the same error "bad file number". So I created a new directory /backups/txlogss, I then copied all the files from /backups/txlogs to /backups/txlogss. Once that was done I deleted the /backups/txlogs directory and then moved the directory /backups/txlogss to /backups/txlogs. Once that was done I tried creating the device again, "ism_add -device /backups/txlogs", this time the device created! I then tried to label the device so that I could mount it; ism_op -label /backups/txlogs -volume TxLogs20180120 -pool ISMDiskLogs And the GODS are against me, I got an error nsrmm: Invalid pool name `ISMDiskLogs'. Now I know the pool name is valid and double checked in the ISM_LOG_POOL value in the onconfig file and it is ISM_LOG_POOL ISMDiskLogs Can anyone help?
I want to thank Andreas Legner who suggested running ism_startup with the -init switch to recreate the pool devices. create_pool Backup ISMDiskData create_pool Backup ISMDiskLogs create_pool Backup ISMData create_pool Backup ISMLogs looking at the ism_startup script I saw this note # The -init switch will cause the ISM server to be setup for the first time. # Using this switch more than once will cause "create failed:" messages to # appear, but will otherwise cause no harm. So I felt it was safe to do. when I ran it I received no errors or create failed messages. So some need pieces must have gone missing in the environment. after running ism_startup -init I was able to label the device and mount it. I had to create a new label rather than use the existing label. I could have deleted the existing label and reused it as an alternative. end result is that my issue is resolved. Thanks again Andreas!