Undroppable columns in table
Posted in 2013
Topics: Server Administration
Hi all, we're using IDS 11.70.FC5 in a DWH environment and did a table-level restore for one of the fact tables. This seemed to work but left two additional columns ifx_tlr_rowid and ifx_tlr_partnum on the table which I wanted to get rid of. As I found out, it is not possible to drop these, or any other column of this table any more! Any 'ALTER TABLE tablename DROP column_name' gives no error, but has no effect and the column column_name still exists. I'm DBA (but not 'informix') on this DB and can rename columns, add new ones and drop them again for that table. Is this a known bug if the restore failed somehow? Some web search found very little information about the ifx_tlr columns and for what they are used. Also, I did not found any special settings for the columns in syscolumns, syscolattribs, syscoldepend, syscolauth. Thanks in advance, Jens
Original post:
Hi all,
we're using IDS 11.70.FC5 in a DWH environment and did a table-level restore
for one of the fact tables.
This seemed to work but left two additional columns ifx_tlr_rowid and
ifx_tlr_partnum on the table which I wanted to get rid of.
As I found out, it is not possible to drop these, or any other column of this
table any more!
Any 'ALTER TABLE tablename DROP column_name' gives no error, but has no effect
and the column column_name still exists.
I'm DBA (but not 'informix') on this DB and can rename columns, add new ones
and drop them again for that table.
Is this a known bug if the restore failed somehow? Some web search found very
little information about the ifx_tlr columns and for what they are used.
Also, I did not found any special settings for the columns in syscolumns,
syscolattribs, syscoldepend, syscolauth.
Thanks in advance,
Jens
Response:
This sounds like it could be a bug. I didn't turn one up with my quick look.
The 2 columns you mention are definitely part of the table level restore, but
from my quick look at code, it looks like they should be added in the start
and dropped at the end. It looks like it might log something about the the
alter (if it skipped undoing the alter) in the default msg.log file
(AC_MSGPATH from the archecker config file). However, I'm not sure how you get
a table into a state where you can add new columns and drop them, but not drop
existing columns. So I'm not sure what's wrong that would be preventing the
alter table drop command from working, and what's worse is if it's really not
returning an error but not actually doing anything. I'd recommend opening aPMR with support for this.
Jacques Renaut
IBM Informix Advanced Support
APD Team