Translating with DrWatson… this can take a few seconds the first time.
This is a genuine, complex translation. DrWatson protects commands, error codes, and log output while naturally translating the surrounding text. It’s translated once and saved.
A user moving to a new PC couldn't get the Informix 32-bit ODBC driver (v3.32) to connect to a Unix server, getting a warning that the displayed locale/codeset (en_US.CP1252) wasn't found on the client and would cause error -23101 "unable to load locale categories", even though the ODBC registry entries matched his old PC. Respondents said the message is typical of INFORMIXDIR not being set on the client (not the Unix box) and suggested checking that I-Connect/Client SDK is properly installed and running SETNET32 to set the environment/registry and test the data sources. The poster never replied, so no confirmed resolution is recorded.
Auto-generated by DrWatson from the posts below — may be imperfect; read the full thread.
I have just changed PC's and am having difficulty getting my Informix
ODBC Driver to work.
We are running Informix on a Unix box, and using Informix driver v 3.32
32bit which was working without any problems on my old PC (and still
is)
However, on my new PC I am getting the following error:-
The displayed locale and codeset have not been found on the client
machine. Using these locale/codeset will result in a -23101 Unable to
load locale categories error. Please install the locales.
The locales being specified in the driver configuration are
en_US.CP1252, and all ODBC Registry Entries are identical on both my
old and new PC's.
Please Help
How can this be?
INFORMIXDIR is set on the Unix Box, and everything is working fine
there
The ODBC settings I am trying to use worked without any problems on the
old PC - just having problems on the new PC
How can this be?
INFORMIXDIR is set on the Unix Box, and everything is working fine
there
The ODBC settings I am trying to use worked without any problems on the
old PC - just having problems on the new PC
Did you run setnet32 on the new pc? Did you test the connections once you
created the datasources? Are you sure INFORMIXDIR is set? What about
ILogin?
gary.cobden@nhs.n
et
Sent by: To
informix-list-bou informix-list@iiug.org
nces@iiug.org cc
Subject
03/24/2006 09:22 Re: ODBC Driver Problems
AM
How can this be?
INFORMIXDIR is set on the Unix Box, and everything is working fine
there
The ODBC settings I am trying to use worked without any problems on the
old PC - just having problems on the new PC
_______________________________________________
Informix-list mailing list
Informix-list@iiug.org
http://www.iiug.org/mailman/listinfo/informix-list
gary.cobden@nhs.net wrote:
> How can this be?
>
> INFORMIXDIR is set on the Unix Box, and everything is working fine
> there
Good. So the problem probably isn't on the Unix box.
> The ODBC settings I am trying to use worked without any problems on the
> old PC - just having problems on the new PC
Oh - and have you done the same registry setup on the new PC that you
did on the old one? SETNET32 might be the tool you need. I'm not an
expert on ODBC or Windows, so I could be spouting nonsense, but the
message (-23101 - cannot load locale categories) you are getting is
fully consistent with INFORMIXDIR not set. Have you got I-Connect or
ClientSDK installed on the PC? Does it have SETNET32 in the Informix
bin directory? Have you used it?
Windows is a weird system - and the registry confuses the heck out of
me. But I strongly suspect the answer lies there.
We use strictly necessary cookies to make this site work. With your
consent we’d also use optional cookies for analytics and marketing. You can accept all,
reject all, or choose. Read our Cookie Policy.