Re: Informix Error -1363
Posted in 1998
According to the folks at Informix, -1363 is caused by writing to an unallocated/invalid memory location. How one can intentionally do this in New Era, I have no idea. But I did notice this error frequently coming up when repeatedly performing queries that return medium-sized to large result sets. Jun Nolasco nolasco@inx.net P.S. Now comes a shameless plug for which I know I will be flamed for: :-) We had so many problems with New Era (have used it since the 1.x days), we decided to junk it in favor of IBM's VisualAge for Smalltalk. I now spend most (if not all) of my time actually solving user problems rather that solving or working around development tool bugs. I no longer experience any memory errors. It is completely stable. There are no more unexplicable crashes or hanging during compiling. Heck, the edit-compile-link-test-debug cycle time in VisualAge (or any other Smalltalk-based tool for that matter) is virtually nil. You can even fix a bug in a program while it is running. There is no need to stop the program, edit, compile, link, and start all over again. Running a window you just built is just a mouse click away. Obviously, productivity went straight up. Why stick to New Era when there are a lot of much better alternatives out there? The place I work for used to be an all-Informix shop. Not anymore. I have shown them the world outside of Informix. :-) Michael G. Thomas wrote: > I get a -1363 error where I performed a large query and return data to > a report format in Windows 3.11. > > Informix version: Informix Online 7.2 Unix > Operating system: Window 3.11, 16mb, 2gb hard-drive > NewEra version: Newera 2.12 WC1 > > Can someone help me!!!! > > Lost in Newera Land? > > M. Thomas