Re: Informix cannot start up properly
Posted in 1998
Keith Moffatt — — source: Informix-list mailing list archive (1991-1998)
JH,
A couple of things. First, you can turn off forced residency in your
onconfig file. That may solve your problem, but the real issue is probably
permissions on your oninit executable. It should be owned by root, group
informix, and have the sticky bit turned on for both the owner and group.
Keith
jh wrote in message <72av1o$mmn$1@mawar.singnet.com.sg>...
>Hi,
>
> When I issue a oninit -s, it give an error message on the console :
>'oninit: forced-resident shared memory not available'. When I look into
the
>message log, there is one line showing : 'Error: Unable to reset open files
>limit, must run as super-user'.
>
>I'm running ODS 7.22 on solaris 2.5.1.
>
>Thanks
>
>JH
>
>