Re: Ontape not starting - IDS9.4TC4 on Win2K
Posted in 2005
Simon Gosney wrote:
> Art, Guy
>
> Thanks for the input. Below are relevant onconfig / environment
> settings:
>
These settings don't look too controversial..
Can you check your command line environment to make sure the variable
SQLIDEBUG is not set? If this was set (presumably by tech support) at
some point it can cause this version of ontape to behave like that (bug
170804).
Once that is ruled out and if E:\\IFMXDATA\\ARTIION.BKP is a valid file
perhaps we could establish whether ontape.exe executes at all or whether
it something prevents it from executing (like a mistaken quarantine from
an anti-virus program for example). Suppose you deliberately unset
INFORMIXSERVER in your environment - does ontape print an error message
to the command line? If it doesn't then I would say check system and
anti-virus logs.
If it does print an error message then it implies there is a bug and
there is additional troubleshooting that can be done to see how far
ontape gets through its initialization process before dying. For example
selectively unsetting INFORMIXDIR and ONCONFIG to see if sensible error
messages are printed.
Regards
Guy
> INFORMIXDIR=d:\\informix
> INFORMIXSERVER=ol_artiion> Path=d:\\informix\\bin;C:\\WINNT\\system32;C:\\WINNT;C:\\WINNT\\System32\\Wbem;d:\\informix\\bin;C:\\Program
> Files\\Symantec\\pcAnywhere\\;C:\\PROGRA~1\\COMMON~1\\CA\\SCANEN~1;C:\\PROGRA~1\\CA\\ETRUST~1
> ONCONFIG=ONCONFIG.ol_artiion>
> TAPEDEV E:\\IFMXDATA\\ARTIION.BKP # Tape device path
> TAPEBLK 16 # Tape block size (Kbytes)
> TAPESIZE 40000000 # Maximum amount of data to put on tape (Kbytes)>
> I don't think it's an onconfig issue as ontape works fine when the
> backup is launched via a batch file as an ARCServe pre-job. However...
> if you run the batch file from the command prompt ontape doesn't
> execute! Will try the proctoken util, onregcheck didn't seem to show
> anything strange :-(
>
> thanks!
>
> Simon
>