Shared libray error at application start
Posted in 2003
Topics: Installation, Setup & Upgrades, Connectivity: ESQL/C, 4GL & Embedded SQL, Platform-Specific Issues, Versions, Editions & End-of-Life
----LNX_Fri_May_16_2003_17:50:31_V3.33-- Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Hello, = we have an ESQL/C application developed with Client SDK 2.50 and running against 9.30.HC2 first and against 9.30.HC4 later. SHLIB_PATH (HP-UX equi= valent of LD_LIBRARY_PATH) wasn't set until now and INFORMIXDIR was set to the IDS installation directory. Last week we did an 'upgrade' from 9.30.HC4 to 9.30.HC5 and the applicati= on didn't start with the following error: /usr/lib/dld.sl: Unresolved symbol: idx_ggetenv (code) from /opt/informix= /lib/libifasf.sl = We found: From 9.30.HC4 to 9.30.HC5 the Connect Software has changed from 2.70 to 2= =2E80 !!! When setting the SHLIB_PATH to the SDK libraries everything works fine! = Did you encounter similar problems? How do you solve (or avoid) such prob= lems? I can imagine a few solutions: - recompiling (developing?) the application with SDK 2.80 - may be not th= at easy :-) ? - installing IDS 9.30.HC5 with an older Connect (e.g. from 9.30.HC4) ? - not using shared libraries - there are a lot of processes running again= st the IDS (wastes memory!) ? - always setting SHLIB_PATH explicitly to the SDK directories with which = the application was developed ? = Another question: If IBM Informix delivers a new SDK, do you update/recompile your applicat= ions or let you run them as long as a update is no must ? = Regards, Andreas Kutsche = ------------------------------------------------ SPAR Oesterreichische Warenhandels-AG Hauptzentrale Europastra=DFe 3 A-5015 Salzburg = Telefon : +43 662 4470 24423 E-Mail : Andreas.KUTSCHE@spar.at Internet: http://www.spar.at ------------------------------------------------ = ----LNX_Fri_May_16_2003_17:50:31_V3.33----
Informix has always had this problem since going to shared libraries, that they occassionally reorganize the libraries (move functions from one lib to another) or eliminate functions. Usually this is involves one of the libraries that they do not have a version naming scheme for so you cannot have multiple versions in the same directory. Normally we do not recompile when installing new engine versions. But when this library glitch occurs then we either install the older iConnect after the engine or compile -static eliminating the problem at the expense of memory. Art S. Kagel ----- Original Message ----- From: Andreas.Kut.... <Andreas.KUTSCHE@spar.at> At: 5/16 12:19 > ----LNX_Fri_May_16_2003_17:50:31_V3.33-- > Content-Type: text/plain; charset="iso-8859-1" > Content-Transfer-Encoding: quoted-printable > > Hello, > = > > we have an ESQL/C application developed with Client SDK 2.50 and running > against 9.30.HC2 first and against 9.30.HC4 later. SHLIB_PATH (HP-UX equi= > valent > of LD_LIBRARY_PATH) wasn't set until now and INFORMIXDIR was set to the > IDS installation directory. > Last week we did an 'upgrade' from 9.30.HC4 to 9.30.HC5 and the applicati= > on > didn't start with the following error: > /usr/lib/dld.sl: Unresolved symbol: idx_ggetenv (code) from /opt/informix= > /lib/libifasf.sl > = > > We found: > From 9.30.HC4 to 9.30.HC5 the Connect Software has changed from 2.70 to 2= > =2E80 !!! > When setting the SHLIB_PATH to the SDK libraries everything works fine! > = > > Did you encounter similar problems? How do you solve (or avoid) such prob= > lems? > I can imagine a few solutions: > - recompiling (developing?) the application with SDK 2.80 - may be not th= > at easy :-) ? > - installing IDS 9.30.HC5 with an older Connect (e.g. from 9.30.HC4) ? > - not using shared libraries - there are a lot of processes running again= > st the IDS (wastes memory!) ? > - always setting SHLIB_PATH explicitly to the SDK directories with which = > the application > was developed ? > = > > Another question: > If IBM Informix delivers a new SDK, do you update/recompile your applicat= > ions or let > you run them as long as a update is no must ? > = > > Regards, > Andreas Kutsche > = > > > ------------------------------------------------ > SPAR Oesterreichische Warenhandels-AG > Hauptzentrale > Europastra=DFe 3 > A-5015 Salzburg > = > > Telefon : +43 662 4470 24423 > E-Mail : Andreas.KUTSCHE@spar.at > Internet: http://www.spar.at > ------------------------------------------------ > > = > > > ----LNX_Fri_May_16_2003_17:50:31_V3.33----
Related threads
- Conversion to differeent characters sets
- Problem in changing locale via dbexport/dbimport
- RE: openlink error "Unable to load locale categories"