Re: IDS-Linux - cannot connect to DS from net
Posted in 1999
Three things:
From: "System.admin. Rubtsovsk Inc." <andrei@rubtsovsk.ru>
>
>Hi, All.
>Sorry for bad english.
>I have Slackware 3.x (kernel 2.0.35) + IDS 7_30_uc7_1,
> Forking 4 'ipcshm' listener threads...succeeded
> Forking 4 'soctcp' listener threads...succeeded
>/etc/services
> sqlexec 1540/tcp
>$INFORMIXDIR/etc/sqlhosts
> sb27049 onipcshm sb270t sqlexec
> sb27049_net onsoctcp sb270t sqlexec
1. AFAIK, you should never have two identical service names ("sqlexec" in
this case) in this file.
>/etc/hosts
> 127.0.0.1 sb270t
2. Shouldn't this be localhost?
> 212.164.48.68 sb270t
>
>All work fine on localhost. But I cannot connect to database server
>from other PC?
>
>/usr/informix/etc > telnet localhost sqlexec
>Trying 127.0.0.1...
>Connected to localhost.
>Escape character is '^]'.
>
>
>/usr/informix/etc > telnet 212.164.48.68 sqlexec
>Trying 212.164.48.68...
>telnet: Unable to connect to remote host: Connection refused
3. I seem to recall there were some problems with network connectivity on
some ports, but I'm just guessing here. You should probably try to get your
hands on Red Hat or Caldera or something...
HTH.
______________________________________________________
Get Your Private, Free Email at http://www.hotmail.com