Re: SHMVIRTSIZE
Posted in 1998
>Hi > >I had a strange problem. I am running SAP on informix. I'd increased >SHMVIRTSIZE parameter recently. After that, I'd shutdown and restarted >both SAP and informix. No problem. Things were fine for a week. Last >weekend we had to install a HP-UX patch. We installed a patch and >rebooted. SAP refused to start. Investigation showed that there was not >enough shared memory for SAP to start. Informix was OK. I changed >SHMVIRTSIZE back to what it was and SAP starts. We even undid the HP-UX >patch, still the same. My question is: > Why did SAP start after I increased SHMVIRTSIZE and not after the >machine was rebooted? > >Any ideas? > >Deepa HP is rather exacting in how shared memory allocations are done at the system level. My guess is that when informix came up first, that the shared memory extents were allocate at the kernel level in such a way that sufficient contigeous memory was not avaliable for SAP. Madison Pruet