assert failed
Posted in 2004
Topics: Error Codes & Troubleshooting
I received the following error on our server while updating a company
symbol. Any ideas as to the cause and solution???
Thanks...
22:30:18 Assert Failed: Dynamic Server 2000 must abort
22:30:18 Informix Dynamic Server 2000 Version 9.21.UC4
22:30:18 Who: Session(138270, user@servername, 39366, -1609288968)
Thread(147105, sqlexec, a0126fb8, 3)
File: rsbuff.c Line: 3618
22:30:18 Results: Dynamic Server 2000 must abort
22:30:18 Action: Reinitialize shared memory
22:30:18 stack trace for pid 20142 written to /tmp/af.42896fba
22:30:18 See Also: /tmp/af.42896fba
22:30:27 rsbuff.c, line 3618, thread 147105, proc id 20142, DynamicServer 2000
must abort.
22:30:27 Fatal error in ADM VP at mt.c:11462
22:30:27 Unexpected virtual processor termination, pid = 20142, exit
= 0x100
22:30:27 PANIC: Attempting to bring system down
Hello, I always meet the similar error before and sent all related log
file to IBM. The only solution from IBM is upgrade our IDS to 9.4....
Anyway, my suggestion is is to read the file trace file
(/tmp/af.42896fba in your case), find out which SQL statement cause the
fault. (I know this is difficult, because the SQL could be run without
any problem after you restart IDS). Good Luck.
Brum wrote:
> I received the following error on our server while updating a company
> symbol. Any ideas as to the cause and solution???
>
> Thanks...
>
> 22:30:18 Assert Failed: Dynamic Server 2000 must abort
> 22:30:18 Informix Dynamic Server 2000 Version 9.21.UC4
> 22:30:18 Who: Session(138270, user@servername, 39366, -1609288968)
> Thread(147105, sqlexec, a0126fb8, 3)
> File: rsbuff.c Line: 3618
> 22:30:18 Results: Dynamic Server 2000 must abort
> 22:30:18 Action: Reinitialize shared memory
> 22:30:18 stack trace for pid 20142 written to /tmp/af.42896fba
> 22:30:18 See Also: /tmp/af.42896fba
> 22:30:27 rsbuff.c, line 3618, thread 147105, proc id 20142, Dynamic> Server 2000
> must abort.
> 22:30:27 Fatal error in ADM VP at mt.c:11462
> 22:30:27 Unexpected virtual processor termination, pid = 20142, exit
> = 0x100
>
> 22:30:27 PANIC: Attempting to bring system down
Take a look at the af file: /tmp/af.42896fba for more information.
You'll sometimes see this type of AF if the physical log has overflowed.
You'd be able to confirm or rule that out from the af file.
Regards
Guy
Brum wrote:
> I received the following error on our server while updating a company
> symbol. Any ideas as to the cause and solution???
>
> Thanks...
>
> 22:30:18 Assert Failed: Dynamic Server 2000 must abort
> 22:30:18 Informix Dynamic Server 2000 Version 9.21.UC4
> 22:30:18 Who: Session(138270, user@servername, 39366, -1609288968)
> Thread(147105, sqlexec, a0126fb8, 3)
> File: rsbuff.c Line: 3618
> 22:30:18 Results: Dynamic Server 2000 must abort
> 22:30:18 Action: Reinitialize shared memory
> 22:30:18 stack trace for pid 20142 written to /tmp/af.42896fba
> 22:30:18 See Also: /tmp/af.42896fba
> 22:30:27 rsbuff.c, line 3618, thread 147105, proc id 20142, Dynamic> Server 2000
> must abort.
> 22:30:27 Fatal error in ADM VP at mt.c:11462
> 22:30:27 Unexpected virtual processor termination, pid = 20142, exit
> = 0x100
>
> 22:30:27 PANIC: Attempting to bring system down
9.21.UC4???
This is unsupported. maybe thats why you are posting on here instead
of calling support?
You haven;t posted the af file, /tmp/af.42896fba, only the online log.
Can you post the stack from the failling thread? and maybe the sql
from the failing thread too?
tbrumley@munder.com (Brum) wrote in message news:<bc21821a.0410081026.7b1b459d@posting.google.com>...
> I received the following error on our server while updating a company
> symbol. Any ideas as to the cause and solution???
>
> Thanks...
>
> 22:30:18 Assert Failed: Dynamic Server 2000 must abort
> 22:30:18 Informix Dynamic Server 2000 Version 9.21.UC4
> 22:30:18 Who: Session(138270, user@servername, 39366, -1609288968)
> Thread(147105, sqlexec, a0126fb8, 3)
> File: rsbuff.c Line: 3618
> 22:30:18 Results: Dynamic Server 2000 must abort
> 22:30:18 Action: Reinitialize shared memory
> 22:30:18 stack trace for pid 20142 written to /tmp/af.42896fba
> 22:30:18 See Also: /tmp/af.42896fba
> 22:30:27 rsbuff.c, line 3618, thread 147105, proc id 20142, Dynamic> Server 2000
> must abort.
> 22:30:27 Fatal error in ADM VP at mt.c:11462
> 22:30:27 Unexpected virtual processor termination, pid = 20142, exit
> = 0x100
>
> 22:30:27 PANIC: Attempting to bring system down