Re: Error in creating table. (Newbie)
Posted in 1995
In article <3ubte4$br@news.unicomp.net>, smeacham@conline.com (Steven D. Meacham) says: > >I am trying to build my first schema on Informix after just having >battled installation. We're using Informix On-Line 5.x on SCO Unix. > >Use the Informix utility to load my .sql file containing definitions >for the new database schema. The following table is the first in my >sql file. No table or key exists that needs to be dropped at this >point. > >It returns an error that I'm creating a duplicate key. <snipped> When you specify -unique- against a field in your schema, Informix very kindly creates an unique index for you. Thus if / when you later try to create a unique index on the same field you get the duplicate key message. The way around this, is either do not use the -unique- against the field, but create your own index, or bung in the -unique- and enjoy the automatically created index 8->