Re: INF4.1 -1 ERROR ?? problem
Posted in 1992
In-Reply-To: <1992Dec23.161421.17027@informix.com> davek@informix.com (David Kosenko) TITLE: Re: INF4.1 -1 ERROR ?? problem In <1992Dec23.161421.17027@informix.com> David Kosenko writes: >Rigby writes: >> >>HELP !!! >>We have just started getting a new error which is described nowhere >>in the INFORMIX literature (whats new): -1. This happens when we >>install our package on UNIX . In one of our package-installation-scripts >>we start tbinit and straight afterwards try a drop database in a 4GL >>program. This gives us an error -1. >> >>Any ideas ?? Is it something to do with tbinit not being quite >>finished ? > > Any error code less that 100 are Unix errors that are propagated back to > the user. The reason they are undocumented in Informix literature is that > they are not necessarily the same across different platforms, so we would > have to have the definitions for each platform we support, which could > wind up being a lot of dead trees ;-0. > > Generally, a -1 error means "Not owner." Is the 4gl program executable by > the id running the install (presumably root)? Surely this should be user informix? | I'm not bad, I'm just drawn that way -- Jessica Rabbit | |------------------------------------------------------------| | Stuart Hemming | shemminga@cix.compulink.co.uk | | Tudor Labels Ltd | uunet!cix.compulink.co.uk!shemminga | | Roman Bank Bourne | Tel : (+44) 778 426444 | | Lincs PE10 9LQ. UK. | Fax : (+44) 778 421862 | Stuart |8-)