RE: database down
Posted in 2003
Bill
Your dbspace demospace1 is DOWN. When did it go down and why? Correct this
problem and then restore from archive.
MW
-----Original Message-----
From: owner-informix-list@iiug.org [mailto:owner-informix-list@iiug.org]On
Behalf Of Bill Hamilton
Sent: Tuesday, 6 May 2003 1:48 a.m.
To: informix-list iiug
Subject: database down
One of our Informix servers locked over the weekend and I'm having trouble
getting it back up (and trying to avoid a restore).
The logs are full and it appears that the main space is full.
Ontape will not backup the logs and will not do a level 0.
There is no disk activity when we try either and it just sits there.
Perhaps there were uncommitted records due to a full space and have a
"deadlock" situation?
I cannot get it to create a new log either.
I cannot get it to add a chunk to the space either.
Suggestions?
----------------------------------------------------------------
this from the log:
Mon May 05 07:57:20 2003
07:57:20 Warning: checkpoint appears to be stalled and is not complete.
08:22:50 WARNING: Checkpoint appears stalled and may not complete before the database server shuts down.
08:22:52 Informix Dynamic Server Stopped.
08:26:56 Could not disable priority aging: errno = 0Mon May 05 08:27:01 2003
08:27:01 DR: DRAUTO is 0 (Off)
08:27:01 Informix Dynamic Server Version 7.31.TD2 Software Serial NumberAAD#J262040
08:27:02 Informix Dynamic Server Initialized -- Shared Memory Initialized.
08:27:02 Physical Recovery Started.
08:27:02 Physical Recovery Complete: 0 Pages Restored.
08:27:02 Logical Recovery Started.
08:27:02 Rollforward of log record failed. iserrno = 126
08:27:02 Log Record: log = 335, pos = 1eb040, type = OLDRSAM:HINSERT(40),
trans = 8
08:27:02 Assert Failed: Chunk 3 is being taken OFFLINE.
08:27:02 Informix Dynamic Server Version 7.31.TD2
08:27:02 Who: Session(8, informix@demo, 0, 0)
Thread(18, xchg_1.1, 0, 1)
File: \\tristarm\\rsam\\rsmirror.c Line: 1784
08:27:02 Results: Dynamic Server will block at next checkpoint
08:27:02 Action: Shutdown (onmode -k) or override (onmode -O)
08:27:15 See Also: af.3fa66a5
08:27:15 Chunk 3 is being taken OFFLINE.
08:27:15 Rollforward of log record failed. iserrno = 126
08:27:15 Log Record: log = 335, pos = 1eb040, type = OLDRSAM:HINSERT(40),
trans = 8
... lots of these
08:27:15 Rollforward of log record failed. iserrno = 101
08:27:15 Log Record: log = 335, pos = 1f2130, type = OLDRSAM:UNIQID(17),
trans = 8
08:27:17 Logical Recovery Complete. 8 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
08:27:18 Dataskip is now OFF for all dbspaces
08:27:18 Init operation complete - Mode Online
08:27:18 On-Line Mode
08:27:29 Checkpoint blocked by down space, waiting for override or shutdown
----------------------------------------------------------------------------
-------------------
oncheck -ce demo
Validating extents...DBspace 'demospace1' is disabled.
ISAM error: Primary and Mirror chunks are bad
-----------------------------------------------------------
oncheck -d
Informix Dynamic Server Version 7.31.TD2 -- On-Line (CKPT REQ) -- Up
00:04:50 -- 17856 KbytesBlocked:CKPT
Dbspaces
address number flags fchunk nchunks flags owner name
c1bc150 1 1 1 1 N informix rootdbs
c1bc570 2 1 2 1 N informix demo
c1bc630 3 5 3 1 ND informix demospace1
3 active, 2047 maximum
Chunks
address chk/dbs offset size free bpages flags pathname
c1bc210 1 1 0 7680 1189 PO-
C:\\IFMXDATA\\demo\\rootdbs_dat.000
c1bc380 2 2 0 12800 12747 PO-
C:\\IFMXDATA\\demo\\demo_dat.000
c1bc478 3 3 0 65536 0 PD-
c:\\IFMXDATA\\demo\\data.dat
3 active, 2047 maximum
NOTE that one space shows 0 free. Could that be true, or would it not be
able to show that because of error?