Re: Error -529: Cannot attach to transaction
Posted in 1997
In article <33C66055.36B3@ccmail.acer.de>, Kai Shen <kai_shen@ccmail.acer.de> writes >Dear all, > >we have one SCO 5.0.2 server running Informix 7.22 and one Altos Unix >running Informix 5. I have a 4GL-program on SCO which attaches to >databases on Altos and inserts some values. Both servers are connected >by TCP/IP and have NETTYPE tlitcp,1,100 set. No more than about ten >people are accessing the Altos server via TCP/IP or Shared Memory. On >SCO there are about 70 users using Informix via Shared Memory. >Now I often, not always, get the error message -529, Cannot attach to >transaction. After repeating the insert for, say, 6 times, the program >will continue with inserting. >Does anyone have an idea for this behaviour? > >Thanks in advance. > >Regards, Kai Under version 5 -529 means -529 Cannot attach to shared memory. Your application program is unable to initialize its connection to the database server because you are using a shared-memory implementation and either: (1) the database shared memory has not been initialized, or (2) the maximum number of users has already started using the system. Check the accompany-ing ISAM error code for more information. Under 6.0 + -529 means -529 Cannot attach to shared memory. (This error message appears in versions prior to Version 6.0.) Your application program is unable to initialize its connection to the data- base server because you are using a shared-memory implementation and either: (1) the database shared memory has not been initialized, or (2) the maximum number of users has already started using the system. Check the accompanying ISAM error code for more information. -529 Cannot attach to transaction. (This error message appears beginning with Version 6.0.) Your appli- cation program is unable to initialize its connection to the database server because you are using a shared-memory implementation and either: (1) the database shared memory has not been initialized, or (2) the maximum number of users has already started using the system. Check the accompanying ISAM error code for more information. ******************************************************************** I would expect the maximum number of users are using the system. ******************************************************************** Under 5 I do not believe NETTYPE is used, instead look for the USERS parameter in $INFORMIXDIR/etc/$TBCONFIG. This is from the INFORMIX-OnLine Administrator's Guide Version 5 Page 3-111. "You can make this change whilst Online is in on-line mode, but the change does not take effect until you reinitialize shared memory... Change the value of USERS. Change the value of LOCKS,BUFFERS or TBLSPACES parameter to match the new number of users, if required." Nuff said! -- David Williams