Re: Error 461: Unable to load locale categories
Posted in 1998
On 11 Sep 1998, Jake Colman wrote: > >>>>> "Jonathan" == Jonathan Leffler <jleffler@informix.com> writes: > > Jonathan> On Fri, 11 Sep 1998, Jake Colman wrote: > >> We develop and sell a software product that uses Informix. Our > >> client base is on Informix 5. In-house we have both Informix 5 > >> and Informix 7. I just rebuilt my app to statically link with > >> the Informix 7 libraries (since RogueWave DBTools requires it) > >> with the expectation that the resultant executable will work > >> with both the Informix 5 and Informix 7 databases. When I try > >> to run the app against my Informix 5 database, I get the 461 > >> error. > >> > >> 1) What does this error mean exactly? > > Jonathan> It means that the version 7 code is looking for files > Jonathan> (specifically GLS files) which are not present in the > Jonathan> version 5 INFORMIXDIR. > > >> 2) Can I even do what I am trying to do? > > Jonathan> No -- witness the errors you are getting. > > Is there any form of Informix 7 run-time that I can easily install at > my client's site that will provide enough of an Informix 7 environment > to make my app happy? We are not ready, at this time, to upgrade our > client's databases to Inforix 7. But, a simple installation of a > runtime product and a change to some environment variables would be > easy enough to do. > > I have heard of a product called CONNECT. Is this the runtime > environment I might be looking for? Yes, probably. You'd want to test it, and you would probably need to use oltlitcp (I-Star) connections because 6.x and later versions of ESQL/C use a whole different connection technology from the version 5 and earlier connection technology. And you'd have to be sure that your 7.x code didn't do anything that a 5.x engine won't know how to do. I'd expect to install the 7.x I-Connect into a different INFORMIXDIR from the main 5.x engine installation -- I wouldn't want to risk trying to overlay 7.x and 5.x technology. And there's no guarantee that this will work at all. The last time I tried to fiddle 7.x ESQL/C and 5.x OnLine in a single INFORMIXDIR, I couldn't get the applications talking to the servers, but I was trying to do a different sort of connectivity from the one I'm suggesting here. This has a better chance of working, but that's different from saying it will work. Note that you'd need I-Star on your machine; one of the many benefits of the 7.x servers is that I-Star is not a separate product. This is getting very messy. It also isn't clear that Informix Technical Support will sanction the connectivity -- I don't think that 7.x applications talking to 5.x servers is supported, even assuming it can be made to work. Yours, Jonathan Leffler (jleffler@informix.com) #include <witticism.h> Guardian of DBD::Informix v0.60 -- http://www.perl.com/CPAN Informix IDN for D4GL & Linux -- http://www.informix.com/idn