I am running IDS.2000 under Linux and am trying to access BLOBs via
ESQL. However, when I try to call ifx_lo_create, the function
returns an error with the error code -9810. However, I looked this up
in the error codes, and the docs said "For more information, check the
accompanying, detailed smart-large-object error code"! I don't know
of any other error codes for this function. rgetlmsg() returns the
same error message as above. Does anyone know how I can get more
information regarding my error? Any help wouldbe greatly
appreciated. A code snippet of what I'm trying to do is below.
EXEC SQL BEGIN DELCARE SECTION;
fixed binary 'blob' ifx_lo_t dataVal_in;
EXEC SQL END DELCARE SECTION;
int8 colSize;
ifx_lo_create_spec_t *colSpec;
char *colDataColName =
"myserver@mydb:mytable.mycolumn";
ifx_lo_def_create_spec(&colSpec);
ifx_lo_col_info(colDataColName, colSpec);
ifx_int8cvint(COL_DATA_LEN, &colSize);
ifx_lo_specset_estbytes(colSpec, &colSize);
ifx_int8cvint(COL_DATA_LEN+2048, &colSize);
ifx_lo_specset_maxbytes(colSpec, &colSize);
if(ifx_lo_create(colSpec, LO_NOBUFFER | LO_RDWR, &dataVal_in,
&blobErrCode) {
// returns above error
rgetlmsg(blobErrCode, errString, ERR_STRING_SIZE, &j);
}
thanks,
Matt