RE: Fatal error in shared memory
Posted in 2004
Topics: Logging & Checkpoints, Platform-Specific Issues
I have encountered and resolved this problem by running the command ipcs and
removing the shared memory segments. As long as you are the owner you can
run the remove command, if not, you must ask the root system admin.
P.S. There are also memory segments that you may need to clean up. The
first column indicates if it is shared segments or memory, hence "m" verses
"s".
-----Original Message-----
From: owner-informix-list@iiug.org
[mailto:owner-informix-list@iiug.org]On Behalf Of Geezer From The
Freezer
Sent: Monday, July 19, 2004 11:28 AM
To: informix-list@iiug.org
Subject: Re: Fatal error in shared memory
Jonathan Leffler wrote:
>
> Geezer From The Freezer wrote:
>
> > Trying to set-up Informix 7.31 UC4 on Solaris 2.6
> > everytime I try and start informix I get
> > oninit: Fatal error in shared memory initialization
> >
> > I have set SHMBASE to 0x1000000 and also tried 0x1000000
> > as suggested in the documentation - both fail.
> >
> > The system has 512Mb of RAM and is a Ultra 10
>
> What's in the online log file (MSGPATH)?
>
> What does 'oninit -v' say?
>
> Have you checked /etc/system?
>
> --
> Jonathan Leffler #include <disclaimer.h>
> Email: jleffler@earthlink.net, jleffler@us.ibm.com
> Guardian of DBD::Informix v2003.04 -- http://dbi.perl.org/
oninit -v looks fine until:-Initialising log/checkpoint information...FAILED
oninit: Fatal error in shared memory initialization
The online.log errors about:
Not Enough Logical Logsfiles, increase 'LOGFILES'
Informix Dynamic Server Stopped
mt_shm_remove: WARNING may not have removed all/correct segments
updated the LOGFILES and LOGSMAX and its working - thanks for the tip
sending to informix-list
"McCabe-Reed, Barbara SIK" wrote: > > I have encountered and resolved this problem by running the command ipcs and > removing the shared memory segments. As long as you are the owner you can > run the remove command, if not, you must ask the root system admin. > > P.S. There are also memory segments that you may need to clean up. The > first column indicates if it is shared segments or memory, hence "m" verses > "s". hmm error persists. ipcs shows no useful output 0 nothing attached unsurprising since informix crashes with the errors in my other post.