the SYSTEM command within NT
Posted in 2001
Topics: Stored Procedures & SPL, Server Administration
Good afternoon Informixers
IIF.2000 on NT 4.0 (and Win2000 Professional)
I am having a little difficulty in extracting the information I need from
the OnLine manuals and would appreciate some pointers from an experienced
individual.
As user JonDoe I connect to the database and create the following simple
procedure to execute a system batch file:-
CREATE PROCEDURE jd_test()SYSTEM 'c:\\dba_bin\\jd_test.bat';
END PROCEDURE;
which creates fine. If I now try and run the procedure it reports back error
"668 - System Command can not be executed error 1 - Not owner". However, if
I connect to the database as Informix it executes without a problem. Can any
of you NT bods out there direct me to the cause and solution ?
Thanks as always;
S.
Don't know about NT, but in Unix I believe this indicates a file system
permissions problem that would be fixed by granting "execute"
permission on the file jd_test.bat to the appropriate entities.
In article <t5r94s7klgm3c5@gxsn.com>,
"Sean Kelsey" <seank@marketinfoserv.com> wrote:
> Good afternoon Informixers
>
> IIF.2000 on NT 4.0 (and Win2000 Professional)
>
> I am having a little difficulty in extracting the information I need
from
> the OnLine manuals and would appreciate some pointers from an
experienced
> individual.
>
> As user JonDoe I connect to the database and create the following
simple
> procedure to execute a system batch file:-
>
> CREATE PROCEDURE jd_test()> SYSTEM 'c:\\dba_bin\\jd_test.bat';
> END PROCEDURE;
>
> which creates fine. If I now try and run the procedure it reports
back error
> "668 - System Command can not be executed error 1 - Not owner".
However, if
> I connect to the database as Informix it executes without a problem.
Can any
> of you NT bods out there direct me to the cause and solution ?
>
> Thanks as always;
>
> S.
>
>
Sent via Deja.com
http://www.deja.com/
Hi, if you want to use SYSTEM command in NT, you have to put "cmd /c" before
your command, for example:
SYSTEM "cmd /c c:\\dba_bin\\jd_test.bat";
It might help.
Jinyao Lin,
Taiwan.
<georhill@my-deja.com> '''g''l'' news:93lp5t$ais$1@nnrp1.deja.com...
> Don't know about NT, but in Unix I believe this indicates a file system
> permissions problem that would be fixed by granting "execute"
> permission on the file jd_test.bat to the appropriate entities.
>
> In article <t5r94s7klgm3c5@gxsn.com>,
> "Sean Kelsey" <seank@marketinfoserv.com> wrote:
> > Good afternoon Informixers
> >
> > IIF.2000 on NT 4.0 (and Win2000 Professional)
> >
> > I am having a little difficulty in extracting the information I need
> from
> > the OnLine manuals and would appreciate some pointers from an
> experienced
> > individual.
> >
> > As user JonDoe I connect to the database and create the following
> simple
> > procedure to execute a system batch file:-
> >
> > CREATE PROCEDURE jd_test()> > SYSTEM 'c:\\dba_bin\\jd_test.bat';
> > END PROCEDURE;
> >
> > which creates fine. If I now try and run the procedure it reports
> back error
> > "668 - System Command can not be executed error 1 - Not owner".
> However, if
> > I connect to the database as Informix it executes without a problem.
> Can any
> > of you NT bods out there direct me to the cause and solution ?
> >
> > Thanks as always;
> >
> > S.
> >
> >
>
>
> Sent via Deja.com
> http://www.deja.com/