moving from one server to another
Posted in 2008
Topics: Storage & Space Management, Error Codes & Troubleshooting, Server Administration
Hi all, I am needing to move an informix 7.31 db from one server Idaho to another server in Texas. I have asked that the following be done and it has been completed. 1. shutdown informix 2. take a backup of the raw logical volumes in Idaho 3. ship the tapes 4. restore to the same raw logical volumes on the texas server. I Have created the links to point to the raw logical volumes and I have a copy of the onconfig file from idaho. I have also set the informixdir var. I am still not able to startup the db on the texas server. I need to know what I am missing. (e.g. files, env vars, etc...) Below is what happens when I try and start up the db. I have to be honset, it has been over 7 years since I did this kind of procedure. Hence I need some major help and detailed steps. Thanks in advance. 11:17:20 Segment locked: addr=0x320000, size=350609408 Wed Mar 5 11:17:21 2008 11:17:21 Event alarms enabled. ALARMPROG = '/informix/PS2/etc/no_log.sh' 11:17:27 DR: DRAUTO is 0 (Off) 11:17:27 Requested shared memory segment size rounded from 2180KB to 2184KB 11:17:27 Informix Dynamic Server Version 7.31.FD2X9 Software Serial Number ACP #J126201 11:17:27 Assert Failed: chunk failed sanity check 11:17:27 Informix Dynamic Server Version 7.31.FD2X9 11:17:27 Who: Session(1, informix@aristot, 0, 354623528) Thread(21, main_loop(), c0000000151fa028, 1) File: rspartn.c Line: 7319 11:17:27 Results: Chunk 1 is being taken OFFLINE. 11:17:27 Action: Restore chunk from archive. If this is a temporary dbspace chunk, drop and add the dbspace to enable it. 11:17:28 See Also: /informix/PS2/dump/af.3fd10c7 11:17:28 I/O error, Primary Chunk '/informix/PS2/sapdata/physdev1/data1' -- Off line (sanity) 11:17:28 Assert Failed: chunk failed sanity check 11:17:28 Informix Dynamic Server Version 7.31.FD2X9 11:17:28 Who: Session(1, informix@aristot, 0, 354623528) Thread(21, main_loop(), c0000000151fa028, 1) File: rspartn.c Line: 7319 11:17:28 Results: Chunk 1 is being taken OFFLINE. 11:17:28 Action: Restore chunk from archive. If this is a temporary dbspace chunk, drop and add the dbspace to enable it. 11:17:29 See Also: /informix/PS2/dump/af.3fd10c7 11:17:29 I/O error, Mirror Chunk '/informix/PS2/sapdata/physdev2/data2' -- Offl ine (sanity) 11:17:29 Informix Dynamic Server Stopped. 11:17:29 mt_shm_remove: WARNING: may not have removed all/correct segments
GARY MARKWALTER wrote: Are the hardware and IDS versions exact including 32bit versus 64bit? Were the raw disk copies taken with the server offline? Are the privs on the RAW chunks set? Personally I would not want to migrate in this way. I'd take an IDS archive and restore it on the target system. Much easier and more reliable. Or even better, bring up the new site as an HDR secondary and just switch it to stand-alone one day, takes 15 seconds to bring the new server online with almost no downtime. Art S. Kagel Oninit > Hi all, > > I am needing to move an informix 7.31 db from one server Idaho to another > server in Texas. I have asked that the following be done and it has been > completed. > 1. shutdown informix > 2. take a backup of the raw logical volumes in Idaho > 3. ship the tapes > 4. restore to the same raw logical volumes on the texas server. > > I Have created the links to point to the raw logical volumes and I have a copy > of the onconfig file from idaho. I have also set the informixdir var. > > I am still not able to startup the db on the texas server. > > I need to know what I am missing. (e.g. files, env vars, etc...) > Below is what happens when I try and start up the db. I have to be honset, it > has been over 7 years since I did this kind of procedure. Hence I need some > major help and detailed steps. Thanks in advance. > > 11:17:20 Segment locked: addr=0x320000, size=350609408 > > Wed Mar 5 11:17:21 2008 > > 11:17:21 Event alarms enabled. ALARMPROG = '/informix/PS2/etc/no_log.sh' > 11:17:27 DR: DRAUTO is 0 (Off) > 11:17:27 Requested shared memory segment size rounded from 2180KB to 2184KB > 11:17:27 Informix Dynamic Server Version 7.31.FD2X9 Software Serial Number ACP > #J126201 > 11:17:27 Assert Failed: chunk failed sanity check > > 11:17:27 Informix Dynamic Server Version 7.31.FD2X9 > 11:17:27 Who: Session(1, informix@aristot, 0, 354623528) > > Thread(21, main_loop(), c0000000151fa028, 1) > > File: rspartn.c Line: 7319 > 11:17:27 Results: Chunk 1 is being taken OFFLINE. > 11:17:27 Action: Restore chunk from archive. If this is a temporary dbspace > > chunk, drop and add the dbspace to enable it. > 11:17:28 See Also: /informix/PS2/dump/af.3fd10c7 > 11:17:28 I/O error, Primary Chunk '/informix/PS2/sapdata/physdev1/data1' -- > Off > line (sanity) > 11:17:28 Assert Failed: chunk failed sanity check > > 11:17:28 Informix Dynamic Server Version 7.31.FD2X9 > 11:17:28 Who: Session(1, informix@aristot, 0, 354623528) > > Thread(21, main_loop(), c0000000151fa028, 1) > > File: rspartn.c Line: 7319 > 11:17:28 Results: Chunk 1 is being taken OFFLINE. > 11:17:28 Action: Restore chunk from archive. If this is a temporary dbspace > > chunk, drop and add the dbspace to enable it. > 11:17:29 See Also: /informix/PS2/dump/af.3fd10c7 > 11:17:29 I/O error, Mirror Chunk '/informix/PS2/sapdata/physdev2/data2' -- > Offl > ine (sanity) > 11:17:29 Informix Dynamic Server Stopped. > 11:17:29 mt_shm_remove: WARNING: may not have removed all/correct segments > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > See you at the IIUG Informix 2008 Conference > The Power Conference for Informix Professionals > April 27 - 30, 2008 Marriott Overland Park (Kansas City), Kansas > http://www.iiug.org/conf > Registration Now Open!! > > ================================================================================ =========== > Please access the attached hyperlink for an important electronic communications disclaimer: > > http://www.oninit.com/home/disclaimer.php > > ================================================================================ =========== > > > ================================================================================ =========== Please access the attached hyperlink for an important electronic communications disclaimer: http://www.oninit.com/home/disclaimer.php ================================================================================ ===========
The versions of Informix must be the same, as must the hardware servers themselves. Make sure all links are properly created and that the raw devices have owner and group equal to "informix' and the permissions are "rw-rw----". also, make sure that the SERVER NAME and all aliases are defined in sqlhosts and in /etc/services. Walter Lowich GARY MARKWALTER <gary.markwalter@hp.com> wrote: Hi all, I am needing to move an informix 7.31 db from one server Idaho to another server in Texas. I have asked that the following be done and it has been completed. 1. shutdown informix 2. take a backup of the raw logical volumes in Idaho 3. ship the tapes 4. restore to the same raw logical volumes on the texas server. I Have created the links to point to the raw logical volumes and I have a copy of the onconfig file from idaho. I have also set the informixdir var. I am still not able to startup the db on the texas server. I need to know what I am missing. (e.g. files, env vars, etc...) Below is what happens when I try and start up the db. I have to be honset, it has been over 7 years since I did this kind of procedure. Hence I need some major help and detailed steps. Thanks in advance. 11:17:20 Segment locked: addr=0x320000, size=350609408 Wed Mar 5 11:17:21 2008 11:17:21 Event alarms enabled. ALARMPROG = '/informix/PS2/etc/no_log.sh' 11:17:27 DR: DRAUTO is 0 (Off) 11:17:27 Requested shared memory segment size rounded from 2180KB to 2184KB 11:17:27 Informix Dynamic Server Version 7.31.FD2X9 Software Serial Number ACP #J126201 11:17:27 Assert Failed: chunk failed sanity check 11:17:27 Informix Dynamic Server Version 7.31.FD2X9 11:17:27 Who: Session(1, informix@aristot, 0, 354623528) Thread(21, main_loop(), c0000000151fa028, 1) File: rspartn.c Line: 7319 11:17:27 Results: Chunk 1 is being taken OFFLINE. 11:17:27 Action: Restore chunk from archive. If this is a temporary dbspace chunk, drop and add the dbspace to enable it. 11:17:28 See Also: /informix/PS2/dump/af.3fd10c7 11:17:28 I/O error, Primary Chunk '/informix/PS2/sapdata/physdev1/data1' -- Off line (sanity) 11:17:28 Assert Failed: chunk failed sanity check 11:17:28 Informix Dynamic Server Version 7.31.FD2X9 11:17:28 Who: Session(1, informix@aristot, 0, 354623528) Thread(21, main_loop(), c0000000151fa028, 1) File: rspartn.c Line: 7319 11:17:28 Results: Chunk 1 is being taken OFFLINE. 11:17:28 Action: Restore chunk from archive. If this is a temporary dbspace chunk, drop and add the dbspace to enable it. 11:17:29 See Also: /informix/PS2/dump/af.3fd10c7 11:17:29 I/O error, Mirror Chunk '/informix/PS2/sapdata/physdev2/data2' -- Offl ine (sanity) 11:17:29 Informix Dynamic Server Stopped. 11:17:29 mt_shm_remove: WARNING: may not have removed all/correct segments ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum. See you at the IIUG Informix 2008 Conference The Power Conference for Informix Professionals April 27 - 30, 2008 Marriott Overland Park (Kansas City), Kansas http://www.iiug.org/conf Registration Now Open!! --------------------------------- Looking for last minute shopping deals? Find them fast with Yahoo! Search.
Hi, if you are sure that database installation/configuration and links are correct you should check if the restore was okay. For example you could look at the contents of the raw devices on the two servers. Example for HPUX: dd if=/informix/PS2/sapdata/physdev1/data1 bs=2048 count=2 | xd -c Compare the output on the two servers and check a few more links/devices. Regards, Andreas > ------------------------------------------- SPAR Österreichische Warenhandels-AG Hauptzentrale A - 5015 Salzburg, Europastrasse 3 FN 34170 a Tel: +43 662 4470 24223 Mobile: +43 664 6259575 E-Mail: Andreas.KUTSCHE@spar.at Internet: http://www.spar.at Wichtiger Hinweis: Der Inhalt dieser E-Mail kann vertrauliche und rechtlich geschützte Informationen, insbesondere Betriebs- oder Geschäftsgeheimnisse, enthalten, zu deren Geheimhaltung der Empfänger verpflichtet ist. Die Informationen in dieser E-Mail sind ausschließlich für den Adressaten bestimmt. Sollten Sie die E-Mail irrtümlich erhalten haben so ersuchen wir Sie, die Nachricht von Ihrem System zu löschen und sich mit uns in Verbindung zu setzen. Über das Internet versandte E-Mails können leicht manipuliert oder unter fremdem Namen erstellt werden. Daher schließen wir die rechtliche Verbindlichkeit der in dieser Nachricht enthaltenen Informationen aus. Der Inhalt der E-Mail ist nur rechtsverbindlich, wenn er von uns schriftlich bestätigt und gezeichnet wird. Sollte trotz der von uns verwendeten Virus-Schutzprogramme durch die Zusendung von E-Mails ein Virus in Ihre Systeme gelangen, haften wir nicht für evtl. hieraus entstehende Schäden. Wir danken für Ihr Verständnis. Important notice: The contents of this e-mail may contain confidential and legally protected information that is in particular related to operational and trade secrets, which the recipient is obliged to treat as confidential. The information in this e-mail is made available exclusively for use by the addressee. In the event that the e-mail may have been sent to you in error, we would ask you to kindly delete this communication from your system and to contact us. E-mails sent via the Internet can be easily manipulated or sent out under someone else's name. We therefore do not accept legal liability for the information contained in this communication. The contents of the e-mail are only legally binding if they have been confirmed and signed by us in writing. If, in spite of our using Antivirus protection software, a virus may have penetrated your system through the sending of this e-mail, we do not accept liability for any damage that may possibly arise as a result of this. We trust that you appreciate our position. ------------------------------------------- -----Ursprüngliche Nachricht----- > Von: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] Im Auftrag von > Walter Lowich > Gesendet: Freitag, 07. März 2008 16:04 > An: ids@iiug.org > Betreff: Re: moving from one server to another [11531] > > The versions of Informix must be the same, as must the hardware servers > themselves. > Make sure all links are properly created and that the raw devices have > owner > and group equal to "informix' and the permissions are "rw-rw----". also, > make > sure that the SERVER NAME and all aliases are defined in sqlhosts and in > /etc/services. > > Walter Lowich > > GARY MARKWALTER <gary.markwalter@hp.com> wrote: > Hi all, > > I am needing to move an informix 7.31 db from one server Idaho to another > server in Texas. I have asked that the following be done and it has been > completed. > 1. shutdown informix > 2. take a backup of the raw logical volumes in Idaho > 3. ship the tapes > 4. restore to the same raw logical volumes on the texas server. > > I Have created the links to point to the raw logical volumes and I have a > copy > of the onconfig file from idaho. I have also set the informixdir var. > > I am still not able to startup the db on the texas server. > > I need to know what I am missing. (e.g. files, env vars, etc...) > Below is what happens when I try and start up the db. I have to be honset, > it > has been over 7 years since I did this kind of procedure. Hence I need > some > major help and detailed steps. Thanks in advance. > > 11:17:20 Segment locked: addr=0x320000, size=350609408 > > Wed Mar 5 11:17:21 2008 > > 11:17:21 Event alarms enabled. ALARMPROG = '/informix/PS2/etc/no_log.sh' > 11:17:27 DR: DRAUTO is 0 (Off) > 11:17:27 Requested shared memory segment size rounded from 2180KB to > 2184KB > 11:17:27 Informix Dynamic Server Version 7.31.FD2X9 Software Serial Number > ACP > #J126201 > 11:17:27 Assert Failed: chunk failed sanity check > > 11:17:27 Informix Dynamic Server Version 7.31.FD2X9 > 11:17:27 Who: Session(1, informix@aristot, 0, 354623528) > > Thread(21, main_loop(), c0000000151fa028, 1) > > File: rspartn.c Line: 7319 > 11:17:27 Results: Chunk 1 is being taken OFFLINE. > 11:17:27 Action: Restore chunk from archive. If this is a temporary > dbspace > > chunk, drop and add the dbspace to enable it. > 11:17:28 See Also: /informix/PS2/dump/af.3fd10c7 > 11:17:28 I/O error, Primary Chunk '/informix/PS2/sapdata/physdev1/data1' - > - > Off > line (sanity) > 11:17:28 Assert Failed: chunk failed sanity check > > 11:17:28 Informix Dynamic Server Version 7.31.FD2X9 > 11:17:28 Who: Session(1, informix@aristot, 0, 354623528) > > Thread(21, main_loop(), c0000000151fa028, 1) > > File: rspartn.c Line: 7319 > 11:17:28 Results: Chunk 1 is being taken OFFLINE. > 11:17:28 Action: Restore chunk from archive. If this is a temporary > dbspace > > chunk, drop and add the dbspace to enable it. > 11:17:29 See Also: /informix/PS2/dump/af.3fd10c7 > 11:17:29 I/O error, Mirror Chunk '/informix/PS2/sapdata/physdev2/data2' -- > Offl > ine (sanity) > 11:17:29 Informix Dynamic Server Stopped. > 11:17:29 mt_shm_remove: WARNING: may not have removed all/correct segments > > > ************************************************************************** > ***** > Forum Note: Use "Reply" to post a response in the discussion forum. > > See you at the IIUG Informix 2008 Conference > The Power Conference for Informix Professionals > April 27 - 30, 2008 Marriott Overland Park (Kansas City), Kansas > http://www.iiug.org/conf > Registration Now Open!! > > --------------------------------- > Looking for last minute shopping deals? Find them fast with Yahoo! Search. > > > ************************************************************************** > ***** > Forum Note: Use "Reply" to post a response in the discussion forum. > > See you at the IIUG Informix 2008 Conference > The Power Conference for Informix Professionals > April 27 - 30, 2008 Marriott Overland Park (Kansas City), Kansas > http://www.iiug.org/conf > Registration Now Open!!