Problems with informix and apache
Posted in 1999
>> I'm trying to install php, apache and informix but, after compiling
>php
>> (--with-informix) always get the same error when i restart apache :
>> 'ifx_module_entry' error.
>
>Did you define informix libs for PHP BEFORE making PHP, as suggested?
Yes I did.
>
>> I suspect this module entry belongs to libifgls.so or libifglx.so.
>Theese
>> libraries are required when i install csdk.rpm
>> and they are not in my linux. (rpm -i --nodeps csdk.rpm)
>
>libifgls is in /opt/informix/lib/esql/libfgls.so and in /usr/lib as
>link
>same for libifglx.
Right. They are in $INFORMIXDIR/lib/esql but not in /usr/lib.
I have included all informix libraries in /usr/lib
ln -s $INFORMIXDIR/lib/lib*so /usr/lib
ln -s $INFORMIXDIR/lib/esql/lib*so /usr/lib
>
>They belong to CSDK installation.
>
>> Could you chech if your linux have theese libraries.
>>
>> I have tryed to install php with informix suport a lot of times (I
>have
>> LD_LIBRARY_PATH defined, my /etc/ld.so.conf is
>> pointing to informix libs, trying with SetEnv in httpd.conf) ... but
>gets
>> always the same error.
>
>Does your LD_LIBRARY_PATH include /usr/lib and/or
>/opt/informix/lib/esql/ ?
>
OK. This is a portion of my /etc/profile (check syntax? I'm running ksh)
INFORMIXDIR=/usr/informix
INFORMIXSERVER="$HOST"_se
ONCONFIG=onconfig.idsDBLANG=en_us/0333
DBDATE=DMY4-DBCENTURY=C
DB_LOCALE=es_es.8859-1DBMONEY=","
DBEDIT=vi
DBPATH=/
INFORMIXTERM=termcap
LD_LIBRARY_PATH="/usr/lib/ /usr/informix/lib /usr/informix/lib/c++ \\/usr/informix/lib/cli /usr/informix/lib/client /usr/informix/lib/dmi \\
/usr/informix/lib/esql"
IFX_LIBDIR_PATH="-L/usr/informix/lib -L/usr/informix/lib/esql"
IFX_INCDIR="/usr/informix/incl/esql"
IFX_LIBS="/usr/informix/lib/esql/libifasf.a \\
/usr/informix/lib/libifasf.a \\
/usr/informix/lib/esql/libifgen.a \\
/usr/informix/lib/esql/libifos.a \\
/usr/informix/lib/esql/libifgls.a \\
-lgen -lgls -lm -ldl /usr/informix/lib/esql/checkapi.o \\
/usr/informix/lib/esql/libifglx.a"
PATH=$PATH:$INFORMIXDIR/bin:/util:/util/central:/usr/ucb:/usr/local/bin:.
export INFORMIXDIR INFORMIXSERVER ONCONFIG DBLANG DBDATE DBCENTURY DB_LOCALEDB\\
MONEY DBEDIT DBPATH INFORMIXTERM PATH LD_LIBRARY_PATH IFX_LIBDIR IFX_INCDIR
IFX\\
_LIBS
With all theese variables defined, I log off from the system and log on as
root.
Then, rebuild php :
../configure --prefix=/usr/local/php-3.0.12 \\
--with-apxs=/usr/local/apache/bin/apxs \\
--with-informix=/usr/informix \\
--with-pgsql=/usr/include/pgsql \\
--enable-track-vars \\
--enable-debug \\
--enable-debugger \\
--with-config-file-path=/usr/local/apache/conf
make
make install
/etc/rc.d/init.d/apache stop
/etc/rc.d/init.d/apache start
and then get the next error :
Syntax error on line 224 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp3.so into server:
/usr/local/apache/
libexec/libphp3.so: undefined symbol: ifx_module_entry
/usr/local/apache/bin/apachectl start: httpd could not be started
'Pero que co'o es el ifx_module_entry de los coj ...?
.