troube setting up a linked server on sql server 20
Posted in 2011
A user setting up a linked server from SQL Server 2008 (x64, Windows 2008 R2) to IDS 11.50 on HP-UX via the Ifxoledbc OLE DB provider (CSDK 3.70.FC3) got error 7399: "Cannot initialize the data source object," with no provider detail. An existing link from SQL Server 2005 worked fine. Suggestions included checking 32- vs 64-bit SDK, confirming the OLE DB setup scripts (coledbp.sql) had been run, and re-running doledb.sql/coledb.sql from the matching CSDK versions. The poster found the real cause himself: SQL Server 2008 was fussier about the data source string format (database@server), and a few attempts at the correct syntax fixed it.
Auto-generated by DrWatson from the posts below — may be imperfect; read the full thread.
Topics: General Discussion
HPUX 11.31 IDS 11.50.FC6; current MSSQL 2005 on w2k3r2; new MSSQL 2008 on w2k8r2 I'm getting the error below when I try to create a link server on our new MSSQL server to our Informix server. We already had a linker server setup on our old MSSQL server to our Informix server for a number of years, so the setup scripts had been run long ago to add the ole tables to sysmaster. I thought I had things setup the same or as close as they can with the 32-bit/64-bit differences. The sdk version is difference 3.50.TC2DE on the old and 3.70.FC3 on the new MSSQL server. Other than that I can't figure out why I'm getting the error. Anyone have suggestions....besides taking a baseball bat to the MSSQL server. :-D John Adamski Sr. Network Specialist Graceland University TITLE: Microsoft SQL Server Management Studio ------------------------------ The linked server has been created but failed a connection test. Do you want to keep the linked server? ------------------------------ ADDITIONAL INFORMATION: An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo) ------------------------------ The OLE DB provider "Ifxoledbc" for linked server "CX" reported an error. The provider did not give any information about the error. Cannot initialize the data source object of OLE DB provider "Ifxoledbc" for linked server "CX". (Microsoft SQL Server, Error: 7399)
Is your MS-SQL Server version a 64bit executable? If not, you may have to back down to the 32bit SDK. Art Art S. Kagel Advanced DataTools (www.advancedatatools.com) Blog: http://informix-myview.blogspot.com/ Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on my employer, Advanced DataTools, the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Thu, Aug 11, 2011 at 1:41 PM, John Adamski <adamski@graceland.edu> wrote: > HPUX 11.31 IDS 11.50.FC6; current MSSQL 2005 on w2k3r2; new MSSQL 2008 on > w2k8r2 > > I'm getting the error below when I try to create a link server on our new > MSSQL server to our Informix server. We already had a linker server setup > on > our old MSSQL server to our Informix server for a number of years, so the > setup scripts had been run long ago to add the ole tables to sysmaster. > > I thought I had things setup the same or as close as they can with the > 32-bit/64-bit differences. The sdk version is difference 3.50.TC2DE on the > old > and 3.70.FC3 on the new MSSQL server. Other than that I can't figure out > why > I'm getting the error. Anyone have suggestions....besides taking a baseball > bat to the MSSQL server. :-D > > John Adamski > Sr. Network Specialist > Graceland University > > TITLE: Microsoft SQL Server Management Studio > ------------------------------ > > The linked server has been created but failed a connection test. Do you > want > to keep the linked server? > > ------------------------------ > ADDITIONAL INFORMATION: > > An exception occurred while executing a Transact-SQL statement or batch. > (Microsoft.SqlServer.ConnectionInfo) > > ------------------------------ > > The OLE DB provider "Ifxoledbc" for linked server "CX" reported an error. > The > provider did not give any information about the error. > Cannot initialize the data source object of OLE DB provider "Ifxoledbc" for > linked server "CX". (Microsoft SQL Server, Error: 7399) > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --20cf307ca34a6cd2fc04aa3e8024
Hi. Have you enabled oledb on your Informix engine? (coledbp.sql) ??? I´ve never seen this, we have several linked servers here, just running.... Regards. Em 11/08/2011 13:41, John Adamski escreveu: > HPUX 11.31 IDS 11.50.FC6; current MSSQL 2005 on w2k3r2; new MSSQL 2008 on > w2k8r2 > > I'm getting the error below when I try to create a link server on our new > MSSQL server to our Informix server. We already had a linker server setup on > our old MSSQL server to our Informix server for a number of years, so the > setup scripts had been run long ago to add the ole tables to sysmaster. > > I thought I had things setup the same or as close as they can with the > 32-bit/64-bit differences. The sdk version is difference 3.50.TC2DE on the old > and 3.70.FC3 on the new MSSQL server. Other than that I can't figure out why > I'm getting the error. Anyone have suggestions....besides taking a baseball > bat to the MSSQL server. :-D > > John Adamski > Sr. Network Specialist > Graceland University > > TITLE: Microsoft SQL Server Management Studio > ------------------------------ > > The linked server has been created but failed a connection test. Do you want > to keep the linked server? > > ------------------------------ > ADDITIONAL INFORMATION: > > An exception occurred while executing a Transact-SQL statement or batch. > (Microsoft.SqlServer.ConnectionInfo) > > ------------------------------ > > The OLE DB provider "Ifxoledbc" for linked server "CX" reported an error. The > provider did not give any information about the error. > Cannot initialize the data source object of OLE DB provider "Ifxoledbc" for > linked server "CX". (Microsoft SQL Server, Error: 7399) > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > -- Alexandre Marini Tecnologia da Informação - DBA SEFAZ-MS / SGI-UGSR / Sistemas IBM-Informix <Cert-Info-Mgmt_color.jpg> IBM Certified System Administrator - Informix Dynamic Server V10 / V11 / V11.70 IBM Information Management Informix Technical Professional v3
Art, The OS and MSSQL should be 64-bit. John -----Original Message----- From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of Art Kagel Sent: Thursday, August 11, 2011 12:56 PM To: ids@iiug.org Subject: Re: troube setting up a linked server on sql s.... [24616] Is your MS-SQL Server version a 64bit executable? If not, you may have to back down to the 32bit SDK. Art Art S. Kagel Advanced DataTools (www.advancedatatools.com) Blog: http://informix-myview.blogspot.com/ Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on my employer, Advanced DataTools, the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Thu, Aug 11, 2011 at 1:41 PM, John Adamski <adamski@graceland.edu> wrote: > HPUX 11.31 IDS 11.50.FC6; current MSSQL 2005 on w2k3r2; new MSSQL 2008 > on > w2k8r2 > > I'm getting the error below when I try to create a link server on our > new MSSQL server to our Informix server. We already had a linker > server setup on our old MSSQL server to our Informix server for a > number of years, so the setup scripts had been run long ago to add the > ole tables to sysmaster. > > I thought I had things setup the same or as close as they can with the > 32-bit/64-bit differences. The sdk version is difference 3.50.TC2DE on > the old and 3.70.FC3 on the new MSSQL server. Other than that I can't > figure out why I'm getting the error. Anyone have > suggestions....besides taking a baseball bat to the MSSQL server. :-D > > John Adamski > Sr. Network Specialist > Graceland University > > TITLE: Microsoft SQL Server Management Studio > ------------------------------ > > The linked server has been created but failed a connection test. Do > you want to keep the linked server? > > ------------------------------ > ADDITIONAL INFORMATION: > > An exception occurred while executing a Transact-SQL statement or batch. > (Microsoft.SqlServer.ConnectionInfo) > > ------------------------------ > > The OLE DB provider "Ifxoledbc" for linked server "CX" reported an error. > The > provider did not give any information about the error. > Cannot initialize the data source object of OLE DB provider > "Ifxoledbc" for linked server "CX". (Microsoft SQL Server, Error: > 7399) > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --20cf307ca34a6cd2fc04aa3e8024 ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.
OK, that's as far as my Windows knowledge goes. ;-( Art Art S. Kagel Advanced DataTools (www.advancedatatools.com) Blog: http://informix-myview.blogspot.com/ Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on my employer, Advanced DataTools, the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Thu, Aug 11, 2011 at 2:26 PM, John Adamski <adamski@graceland.edu> wrote: > Art, > > The OS and MSSQL should be 64-bit. > > John > > -----Original Message----- > From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of Art > Kagel > Sent: Thursday, August 11, 2011 12:56 PM > To: ids@iiug.org > Subject: Re: troube setting up a linked server on sql s.... [24616] > > Is your MS-SQL Server version a 64bit executable? If not, you may have to > back > down to the 32bit SDK. > > Art > > Art S. Kagel > Advanced DataTools (www.advancedatatools.com) > Blog: http://informix-myview.blogspot.com/ > > Disclaimer: Please keep in mind that my own opinions are my own opinions > and > do not reflect on my employer, Advanced DataTools, the IIUG, nor any other > organization with which I am associated either explicitly, implicitly, or > by > inference. Neither do those opinions reflect those of other individuals > affiliated with any entity with which I am affiliated nor those of the > entities themselves. > > On Thu, Aug 11, 2011 at 1:41 PM, John Adamski <adamski@graceland.edu> > wrote: > > > HPUX 11.31 IDS 11.50.FC6; current MSSQL 2005 on w2k3r2; new MSSQL 2008 > > on > > w2k8r2 > > > > I'm getting the error below when I try to create a link server on our > > new MSSQL server to our Informix server. We already had a linker > > server setup on our old MSSQL server to our Informix server for a > > number of years, so the setup scripts had been run long ago to add the > > ole tables to sysmaster. > > > > I thought I had things setup the same or as close as they can with the > > 32-bit/64-bit differences. The sdk version is difference 3.50.TC2DE on > > the old and 3.70.FC3 on the new MSSQL server. Other than that I can't > > figure out why I'm getting the error. Anyone have > > suggestions....besides taking a baseball bat to the MSSQL server. :-D > > > > John Adamski > > Sr. Network Specialist > > Graceland University > > > > TITLE: Microsoft SQL Server Management Studio > > ------------------------------ > > > > The linked server has been created but failed a connection test. Do > > you want to keep the linked server? > > > > ------------------------------ > > ADDITIONAL INFORMATION: > > > > An exception occurred while executing a Transact-SQL statement or batch. > > (Microsoft.SqlServer.ConnectionInfo) > > > > ------------------------------ > > > > The OLE DB provider "Ifxoledbc" for linked server "CX" reported an error. > > The > > provider did not give any information about the error. > > Cannot initialize the data source object of OLE DB provider > > "Ifxoledbc" for linked server "CX". (Microsoft SQL Server, Error: > > 7399) > > > > > > > > > > > ******************************************************************************* > > Forum Note: Use "Reply" to post a response in the discussion forum. > > > > > > --20cf307ca34a6cd2fc04aa3e8024 > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --20cf307ca1a24d5fc804aa3f26e2
I remember having difficulty with a linked server when we upgraded our CSDK from 2.9 to 3.5. We had to run the doledb.sql script from the 2.9 version and then the coledb.sql script from the 3.5 version to get it going. If I remember right, the ole in the newer CSDK expected a slightly different table structure on the ole transformation tables. You may want to try running the 3.5 doledb.sql followed by the coledb.sql from 3.7. At worst, it shouldn't hurt anything. --EEM >-----Original Message----- >From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of >John Adamski >Sent: Thursday, August 11, 2011 1:26 PM >To: ids@iiug.org >Subject: RE: troube setting up a linked server on sql s.... [24618] > >Art, > >The OS and MSSQL should be 64-bit. > >John > >-----Original Message----- >From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of >Art Kagel >Sent: Thursday, August 11, 2011 12:56 PM >To: ids@iiug.org >Subject: Re: troube setting up a linked server on sql s.... [24616] > >Is your MS-SQL Server version a 64bit executable? If not, you may have >to back down to the 32bit SDK. > >Art > >Art S. Kagel >Advanced DataTools (www.advancedatatools.com) >Blog: http://informix-myview.blogspot.com/ > >Disclaimer: Please keep in mind that my own opinions are my own opinions >and do not reflect on my employer, Advanced DataTools, the IIUG, nor any >other organization with which I am associated either explicitly, >implicitly, or by inference. Neither do those opinions reflect those of >other individuals affiliated with any entity with which I am affiliated >nor those of the entities themselves. > >On Thu, Aug 11, 2011 at 1:41 PM, John Adamski <adamski@graceland.edu> >wrote: > >> HPUX 11.31 IDS 11.50.FC6; current MSSQL 2005 on w2k3r2; new MSSQL 2008 >> on >> w2k8r2 >> >> I'm getting the error below when I try to create a link server on our >> new MSSQL server to our Informix server. We already had a linker >> server setup on our old MSSQL server to our Informix server for a >> number of years, so the setup scripts had been run long ago to add the >> ole tables to sysmaster. >> >> I thought I had things setup the same or as close as they can with the >> 32-bit/64-bit differences. The sdk version is difference 3.50.TC2DE on >> the old and 3.70.FC3 on the new MSSQL server. Other than that I can't >> figure out why I'm getting the error. Anyone have >> suggestions....besides taking a baseball bat to the MSSQL server. :-D >> >> John Adamski >> Sr. Network Specialist >> Graceland University >> >> TITLE: Microsoft SQL Server Management Studio >> ------------------------------ >> >> The linked server has been created but failed a connection test. Do >> you want to keep the linked server? >> >> ------------------------------ >> ADDITIONAL INFORMATION: >> >> An exception occurred while executing a Transact-SQL statement or >batch. >> (Microsoft.SqlServer.ConnectionInfo) >> >> ------------------------------ >> >> The OLE DB provider "Ifxoledbc" for linked server "CX" reported an >error. >> The >> provider did not give any information about the error. >> Cannot initialize the data source object of OLE DB provider >> "Ifxoledbc" for linked server "CX". (Microsoft SQL Server, Error: >> 7399) >> >> >> >> > >************************************************************************ >******* >> Forum Note: Use "Reply" to post a response in the discussion forum. >> >> > >--20cf307ca34a6cd2fc04aa3e8024 > > >************************************************************************ >******* >Forum Note: Use "Reply" to post a response in the discussion forum. > > >************************************************************************ >******* > Forum Note: Use "Reply" to post a response in the discussion forum.
We finally got it figured out. It was the data source it seems that sql server 2008 is pickier on how you define your database@server. Once I figured out the data source was what sql server didn't like, it took a couple of tries to figure out what it wanted. John -----Original Message----- From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of Everett Mills Sent: Thursday, August 11, 2011 2:49 PM To: ids@iiug.org Subject: RE: troube setting up a linked server on sql s.... [24621] I remember having difficulty with a linked server when we upgraded our CSDK from 2.9 to 3.5. We had to run the doledb.sql script from the 2.9 version and then the coledb.sql script from the 3.5 version to get it going. If I remember right, the ole in the newer CSDK expected a slightly different table structure on the ole transformation tables. You may want to try running the 3.5 doledb.sql followed by the coledb.sql from 3.7. At worst, it shouldn't hurt anything. --EEM >-----Original Message----- >From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of >John Adamski >Sent: Thursday, August 11, 2011 1:26 PM >To: ids@iiug.org >Subject: RE: troube setting up a linked server on sql s.... [24618] > >Art, > >The OS and MSSQL should be 64-bit. > >John > >-----Original Message----- >From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of >Art Kagel >Sent: Thursday, August 11, 2011 12:56 PM >To: ids@iiug.org >Subject: Re: troube setting up a linked server on sql s.... [24616] > >Is your MS-SQL Server version a 64bit executable? If not, you may have >to back down to the 32bit SDK. > >Art > >Art S. Kagel >Advanced DataTools (www.advancedatatools.com) >Blog: http://informix-myview.blogspot.com/ > >Disclaimer: Please keep in mind that my own opinions are my own >opinions and do not reflect on my employer, Advanced DataTools, the >IIUG, nor any other organization with which I am associated either >explicitly, implicitly, or by inference. Neither do those opinions >reflect those of other individuals affiliated with any entity with >which I am affiliated nor those of the entities themselves. > >On Thu, Aug 11, 2011 at 1:41 PM, John Adamski <adamski@graceland.edu> >wrote: > >> HPUX 11.31 IDS 11.50.FC6; current MSSQL 2005 on w2k3r2; new MSSQL >> 2008 on >> w2k8r2 >> >> I'm getting the error below when I try to create a link server on our >> new MSSQL server to our Informix server. We already had a linker >> server setup on our old MSSQL server to our Informix server for a >> number of years, so the setup scripts had been run long ago to add >> the ole tables to sysmaster. >> >> I thought I had things setup the same or as close as they can with >> the 32-bit/64-bit differences. The sdk version is difference >> 3.50.TC2DE on the old and 3.70.FC3 on the new MSSQL server. Other >> than that I can't figure out why I'm getting the error. Anyone have >> suggestions....besides taking a baseball bat to the MSSQL server. :-D >> >> John Adamski >> Sr. Network Specialist >> Graceland University >> >> TITLE: Microsoft SQL Server Management Studio >> ------------------------------ >> >> The linked server has been created but failed a connection test. Do >> you want to keep the linked server? >> >> ------------------------------ >> ADDITIONAL INFORMATION: >> >> An exception occurred while executing a Transact-SQL statement or >batch. >> (Microsoft.SqlServer.ConnectionInfo) >> >> ------------------------------ >> >> The OLE DB provider "Ifxoledbc" for linked server "CX" reported an >error. >> The >> provider did not give any information about the error. >> Cannot initialize the data source object of OLE DB provider >> "Ifxoledbc" for linked server "CX". (Microsoft SQL Server, Error: >> 7399) >> >> >> >> > >*********************************************************************** >* >******* >> Forum Note: Use "Reply" to post a response in the discussion forum. >> >> > >--20cf307ca34a6cd2fc04aa3e8024 > > >*********************************************************************** >* >******* >Forum Note: Use "Reply" to post a response in the discussion forum. > > >*********************************************************************** >* >******* > Forum Note: Use "Reply" to post a response in the discussion forum. ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.