Lock problem
Posted in 1999
St�fane Ruel — — source: Informix-list mailing list archive (1991-1998)
Hi, I use informix online 5.1. As mentionned in the documentation, I periodictly do a "Update statistics" on the tables. Sometimes, I have problem after this operation. I have what seems to be a lock problem. I have an ISAM error and a SQL error that report that there is a timeout or a possible deadlock. This problem occurs when one person write to a table and another is reading the same table. The lock mode is Row for all the tables. Is this a known problem of "Update statistics" ? Is there a workaround? Thanks!