onbar restore
Posted in 2012
Solaris 9. Informix 11.50
Had damage on disk and two dbspaces were offline when try to start IDS.
Informix startup stays on
23:43:43 Results: DBspace bddarea1 is disabled.
23:43:43 Action: Restore DBspace bddarea1
23:43:43 stack trace for pid 10581 written
to /usr1/informix1150/tmp/af.40c861e
23:43:43 See Also: /usr1/informix1150/tmp/af.40c861e
23:43:44 Chunk 2 is being taken OFFLINE.
23:43:44 Rollforward of log record failed. iserrno = 126
23:43:44 Log Record: log = 21873, pos = 0x18863e4, type =
OLDRSAM:HUPDATE(73), trans = 44
23:43:44 Rollforward of log record failed. iserrno = 135
etc.
ids state is
IBM Informix Dynamic Server Version 11.50.FC5 -- Fast Recovery -- Up
00:35:39 -- 1892352 Kbytesbut not moving.
When I try to onbar -r or onbar -r bddarea1
then stops because logical logs is on process
2012-04-30 23:56:51 11703 11701 Unable to start the storage space
restore: A Logical Restore is already occurring..
2012-04-30 23:56:56 11703 11701 (-43140) Due to the previous error,
logical restore will not be attempted.
2012-04-30 23:56:56 11703 11701 /usr1/informix1150/bin/onbar_d
complete, returning 131 (0x83)
Any idea? any help?
Thanks in advance.
--Nestor