RE: have you installed the Informix jdbc driver on
Posted in 2014
Topics: Installation, Setup & Upgrades, Stored Procedures & SPL, Connectivity: ODBC / JDBC / .NET, Server Administration, Platform-Specific Issues, Java & JDBC Development
Red hat 6 is the OS, and I tried: JDBC.3.50.JC9.tar JDBC_3.50xc5.tar And both versions gave the error: "The wizard cannot continue because of the following error: could not load wizard specified in /wizard.inf (104)". When I tried JDBC.4.10.JC3DE.tar, I could not get pass: "Could not find the main class: run. Program will exit." Mary Villagomez Sr. Technologist, I&TG Informix/MySQL DBA - Database Management Sears Holdings Corporation, Inc 3333 Beverly Road B2-260A Hoffman Estates, IL 60179 Email: Mary.Villagomez@searshc.com<mailto:Mary.Villagomez@searshc.com> Phone: 847-286-1768 Pager: 2244650493@sprint.skytel.com<mailto:2244650493@sprint.skytel.com> Refer to the DBA Wiki page link below for more information: http://wiki.intra.sears.com/confluence/display/TechStrag/Database+Management#Dat abaseManagement<http://wiki.intra.sears.com/confluence/display/TechStrag/Databas e+Management> From: Villagomez, Mary Sent: Monday, March 24, 2014 10:14 AM To: Knox, Ernest Subject: RE: have you installed the Informix jdbc driver on a new Linux VM recently? I am working with Randy, and he got the same error as I did. Thus, I am working to resolve it. I had this error when I installed the Informix software for the new Odyssey Vms and was able to get around it with the '-javahome' parm. However, that quick fix is not working now. I will continue to review. Thanks anyway! Mary Villagomez Sr. Technologist, I&TG Informix/MySQL DBA - Database Management Sears Holdings Corporation, Inc 3333 Beverly Road B2-260A Hoffman Estates, IL 60179 Email: Mary.Villagomez@searshc.com<mailto:Mary.Villagomez@searshc.com> Phone: 847-286-1768 Pager: 2244650493@sprint.skytel.com<mailto:2244650493@sprint.skytel.com> Refer to the DBA Wiki page link below for more information: http://wiki.intra.sears.com/confluence/display/TechStrag/Database+Management#Dat abaseManagement<http://wiki.intra.sears.com/confluence/display/TechStrag/Databas e+Management> This message, including any attachments, is the property of Sears Holdings Corporation and/or one of its subsidiaries. It is confidential and may contain proprietary or legally privileged information. If you are not the intended recipient, please delete it without reading the contents. Thank you.
Try downloading the Oracle java package instead of the OpenJava that RH has installed ??? Anyone else see the funny side of needing Oracle Java to install an Informix database :) Why you need a working Java environment is a whole different discussion Cheers Paul > Red hat 6 is the OS, and I tried: > > JDBC.3.50.JC9.tar > JDBC_3.50xc5.tar > > And both versions gave the error: "The wizard cannot continue because of > the > following error: could not load wizard specified in /wizard.inf (104)". > > When I tried JDBC.4.10.JC3DE.tar, I could not get pass: "Could not find > the > main class: run. Program will exit." > > Mary Villagomez > Sr. Technologist, I&TG > Informix/MySQL DBA - Database Management > Sears Holdings Corporation, Inc > 3333 Beverly Road B2-260A > Hoffman Estates, IL 60179 > Email: Mary.Villagomez@searshc.com<mailto:Mary.Villagomez@searshc.com> > Phone: 847-286-1768 > Pager: 2244650493@sprint.skytel.com<mailto:2244650493@sprint.skytel.com> > > Refer to the DBA Wiki page link below for more information: > > http://wiki.intra.sears.com/confluence/display/TechStrag/Database+Management#Dat abaseManagement<http://wiki.intra.sears.com/confluence/display/TechStrag/Databas e+Management> > > From: Villagomez, Mary > Sent: Monday, March 24, 2014 10:14 AM > To: Knox, Ernest > Subject: RE: have you installed the Informix jdbc driver on a new Linux VM > recently? > > I am working with Randy, and he got the same error as I did. Thus, I am > working to resolve it. I had this error when I installed the Informix > software > for the new Odyssey Vms and was able to get around it with the '-javahome' > parm. However, that quick fix is not working now. I will continue to > review. > > Thanks anyway! > > Mary Villagomez > Sr. Technologist, I&TG > Informix/MySQL DBA - Database Management > Sears Holdings Corporation, Inc > 3333 Beverly Road B2-260A > Hoffman Estates, IL 60179 > Email: Mary.Villagomez@searshc.com<mailto:Mary.Villagomez@searshc.com> > Phone: 847-286-1768 > Pager: 2244650493@sprint.skytel.com<mailto:2244650493@sprint.skytel.com> > > Refer to the DBA Wiki page link below for more information: > > http://wiki.intra.sears.com/confluence/display/TechStrag/Database+Management#Dat abaseManagement<http://wiki.intra.sears.com/confluence/display/TechStrag/Databas e+Management> > > This message, including any attachments, is the property of Sears Holdings > Corporation and/or one of its subsidiaries. It is confidential and may > contain > proprietary or legally privileged information. If you are not the intended > recipient, please delete it without reading the contents. Thank you. > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > -- Paul Watson Tel: +1 913-674-0360 Mob: +1 913-387-7529 Web: www.oninit.com Failure is not as frightening as regret. If you want to improve, be content to be thought foolish and stupid. What this country needs are more unemployed politicians
You probably can install it with IBM JVM. But I can see the funny part... In this particular case, you need a working java environment because the installer is a JAR. And although we could supply a working java inside the package as we do for the engine and clientsdk, it would be a bit of waste since if you're installing a JDBC driver you'll need a working java environment anyway :) But yes... run it with the Oracle JRE... You know java... write once, ru(i)n everywhere :) Regards. On Mon, Mar 24, 2014 at 5:56 PM, Paul Watson <paul@oninit.com> wrote: > Try downloading the Oracle java package instead of the OpenJava that RH > has installed ??? > > Anyone else see the funny side of needing Oracle Java to install an > Informix database :) Why you need a working Java environment is a whole > different discussion > > Cheers > Paul > > > Red hat 6 is the OS, and I tried: > > > > JDBC.3.50.JC9.tar > > JDBC_3.50xc5.tar > > > > And both versions gave the error: "The wizard cannot continue because of > > the > > following error: could not load wizard specified in /wizard.inf (104)". > > > > When I tried JDBC.4.10.JC3DE.tar, I could not get pass: "Could not find > > the > > main class: run. Program will exit." > > > > Mary Villagomez > > Sr. Technologist, I&TG > > Informix/MySQL DBA - Database Management > > Sears Holdings Corporation, Inc > > 3333 Beverly Road B2-260A > > Hoffman Estates, IL 60179 > > Email: Mary.Villagomez@searshc.com<mailto:Mary.Villagomez@searshc.com> > > Phone: 847-286-1768 > > Pager: 2244650493@sprint.skytel.com<mailto:2244650493@sprint.skytel.com> > > > > Refer to the DBA Wiki page link below for more information: > > > > > > http://wiki.intra.sears.com/confluence/display/TechStrag/Database+Management#Dat abaseManagement > < > http://wiki.intra.sears.com/confluence/display/TechStrag/Database+Management > > > > > > From: Villagomez, Mary > > Sent: Monday, March 24, 2014 10:14 AM > > To: Knox, Ernest > > Subject: RE: have you installed the Informix jdbc driver on a new Linux > VM > > recently? > > > > I am working with Randy, and he got the same error as I did. Thus, I am > > working to resolve it. I had this error when I installed the Informix > > software > > for the new Odyssey Vms and was able to get around it with the > '-javahome' > > parm. However, that quick fix is not working now. I will continue to > > review. > > > > Thanks anyway! > > > > Mary Villagomez > > Sr. Technologist, I&TG > > Informix/MySQL DBA - Database Management > > Sears Holdings Corporation, Inc > > 3333 Beverly Road B2-260A > > Hoffman Estates, IL 60179 > > Email: Mary.Villagomez@searshc.com<mailto:Mary.Villagomez@searshc.com> > > Phone: 847-286-1768 > > Pager: 2244650493@sprint.skytel.com<mailto:2244650493@sprint.skytel.com> > > > > Refer to the DBA Wiki page link below for more information: > > > > > > http://wiki.intra.sears.com/confluence/display/TechStrag/Database+Management#Dat abaseManagement > < > http://wiki.intra.sears.com/confluence/display/TechStrag/Database+Management > > > > > > This message, including any attachments, is the property of Sears > Holdings > > Corporation and/or one of its subsidiaries. It is confidential and may > > contain > > proprietary or legally privileged information. If you are not the > intended > > recipient, please delete it without reading the contents. Thank you. > > > > > > > > ******************************************************************************* > > Forum Note: Use "Reply" to post a response in the discussion forum. > > > > -- > Paul Watson > Tel: +1 913-674-0360 > Mob: +1 913-387-7529 > Web: www.oninit.com > > Failure is not as frightening as regret. > If you want to improve, be content to be thought foolish and stupid. > What this country needs are more unemployed politicians > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > -- Fernando Nunes Portugal http://informix-technology.blogspot.com My email works... but I don't check it frequently... --001a11c1da06f7fb8d04f55ef9a6