Re: Informix error -208
Posted in 1991
>> From uunet!rmy.emory.edu!informix-list-owner Fri Oct 18 15:59:08 1991 >> From: uunet!att.att.com!lzatt!lzredfs1!lzatt!jel >> Original-From: jel@lzatt (-jim laur(AH0756)) >> To: informix-list@rmy.emory.edu >> Subject: Informix error -208 >> Cc: jel@lzatt, mm@lzatt >> >> We are running Informix-ESQL 4.10 on a SUN 490 using >> Informix on-line as the back-end engine. >> We have a process which makes approximately 42 prepare calls and >> 16 declares of cursors. >> After doing a fair percentage of these statements the prepares >> start failing with sqlca.sqlcode = -208 (Memory allocation failed during >> query processing. Reduce the complexity of your query or program). >> If I reverse the order of the prepares a different one will fail and >> the one that had failed will work. >> Hence I suspect a limitation on the number of prepares as opposed to a problem >> with any one particular prepare. >> I recognize that I can free and re-prepare but this will incur a >> performance cost I'd rather not take. >> I also plan on restructuring my code so as to do all the prepares at start-up >> time so at least I know right away and not later if I have a problem (my >> process is a daemon and hence is up forever handling database requests). >> >> THANKS!! >> Jim Laur AT&T Bell Labs, Rm 3M-317, 307 Middletown-Lincroft Rd, Lincroft N.J. The problem is probably that the default shared memory base address is too low for your setup. Assuming that you have a reasonable amount of memory (say, 12MB or more), try bumping SHMBASE up. The current default of 0x100000 is really too low; I'm using 0x400000 with no problems on an IPC with 12 MB. You shouldn't have to go through any coding hoops, in any event. -- Alan Denney # aland@informix.com # {pyramid|uunet}!infmx!aland "Yeah, I'm gonna miss the U.S.A. I guess I'll miss it every single day But no one loves me here anyway I know my plane is due." - "Katmandu"