Cannot start IDS with kaio on RedHat
Posted in 2006
Topics: Performance & Tuning, Error Codes & Troubleshooting, Versions, Editions & End-of-Life
IDS 10.0 UC5 on RHEL 4 AS
If I disable kaio it's fine but if not ...
Probably a kernel tuning thing but I can't for the life of me see what.
Any ideas?
thx
Neil
13:01:30 Event alarms enabled. ALARMPROG =
'/opt/informix/10.0/etc/alarmprogram.sh'
13:01:30 Booting Language <c> from module <>
13:01:30 Loading Module <CNULL>
13:01:30 Booting Language <builtin> from module <>
13:01:30 Loading Module <BUILTINNULL>
13:01:35 DR: DRAUTO is 0 (Off)
13:01:35 IBM Informix Dynamic Server Version 10.00.UC5 Software SerialNumber AAA#B000000
13:01:36 Assert Failed: initializing KAIO failed
13:01:36 IBM Informix Dynamic Server Version 10.00.UC5
13:01:36 Who: Session(1, informix@orbisdb01, 0, (nil))
Thread(29, kaio, 0, 1)
File: kaioapi.c Line: 246
13:01:36 Results: io_queue_init(4096) failed returning -22, errno = 0
13:01:36 stack trace for pid 4419 written to
/opt/informix/10.0/tmp/af.405d91f
13:01:36 See Also: /opt/informix/10.0/tmp/af.405d91f
13:01:37 initializing KAIO failed
13:01:37 io_queue_init(4096) failed returning -22, errno = 0
13:01:37 Assert Failed: initializing KAIO failed
Do you have correct kaio library installed?
Quering rpm should look someting like this:
$ rpm -qa|grep aio
libaio-0.3.105-2
Also check $INFORMIXDIR/release/en_us/0333/ids_machine_notes_10.00.txt
Neil Truby wrote:
> IDS 10.0 UC5 on RHEL 4 AS
>
> If I disable kaio it's fine but if not ...
>
> Probably a kernel tuning thing but I can't for the life of me see what.
>
> Any ideas?
>
> thx
> Neil
>
> 13:01:30 Event alarms enabled. ALARMPROG =
> '/opt/informix/10.0/etc/alarmprogram.sh'
> 13:01:30 Booting Language <c> from module <>
> 13:01:30 Loading Module <CNULL>
> 13:01:30 Booting Language <builtin> from module <>
> 13:01:30 Loading Module <BUILTINNULL>
> 13:01:35 DR: DRAUTO is 0 (Off)
> 13:01:35 IBM Informix Dynamic Server Version 10.00.UC5 Software Serial> Number AAA#B000000
> 13:01:36 Assert Failed: initializing KAIO failed
> 13:01:36 IBM Informix Dynamic Server Version 10.00.UC5
> 13:01:36 Who: Session(1, informix@orbisdb01, 0, (nil))
> Thread(29, kaio, 0, 1)
> File: kaioapi.c Line: 246
> 13:01:36 Results: io_queue_init(4096) failed returning -22, errno = 0
> 13:01:36 stack trace for pid 4419 written to
> /opt/informix/10.0/tmp/af.405d91f
> 13:01:36 See Also: /opt/informix/10.0/tmp/af.405d91f
> 13:01:37 initializing KAIO failed
> 13:01:37 io_queue_init(4096) failed returning -22, errno = 0
> 13:01:37 Assert Failed: initializing KAIO failed>
>
>
"Claus Samuelsen" <csa@dk.ibm.com> wrote in message
news:44b9fc7f$0$14028$edfadb0f@dread15.news.tele.dk...
> Do you have correct kaio library installed?
> Quering rpm should look someting like this:
>
> $ rpm -qa|grep aio
> libaio-0.3.105-2
Yes, I think so ...
rpm -qa | grep aio
libaio-0.3.105-2
... although I was going to try an older one, so if you know if works with
that version it'll save me the bother.
> Also check $INFORMIXDIR/release/en_us/0333/ids_machine_notes_10.00.txt
Yes, I'm sure I have checked all the kernel parms etc.
A bit stuck on this one, and I need to get on with it, so it's frustrating
that I'll have to wait until Mon am to raise a support call.
cheers
Neil
"Neil Truby" <neil.truby@ardenta.com> wrote in message news:4hskbuF13g8rU1@individual.net... > IDS 10.0 UC5 on RHEL 4 AS > > If I disable kaio it's fine but if not ... > > Probably a kernel tuning thing but I can't for the life of me see what. IBM case Problem Management Record 91257,999,866 refers -- Neil Truby t:01932 724027 Director m:07798 811708 Ardenta Limited e:neil.truby@ardenta.com
"Neil Truby" <neil.truby@ardenta.com> wrote in message news:4i12ecF1kpddU1@individual.net... > "Neil Truby" <neil.truby@ardenta.com> wrote in message > news:4hskbuF13g8rU1@individual.net... >> IDS 10.0 UC5 on RHEL 4 AS >> >> If I disable kaio it's fine but if not ... >> >> Probably a kernel tuning thing but I can't for the life of me see what. > > > > IBM case Problem Management Record 91257,999,866 refers Apparently it's bug 176987 32-BIT IDS ON 64-BIT LINUX KERNEL CAN FAIL WHEN TRYING TO USE KAIO. The fixes are either to upgrade to RHEL AS 4 Update 4 (which is not available to us yet), or use 10.0FCx instead. The reason we didn't use FCx in the first place is that that fails during the branding at install time. So we've now raised a call for that problem.