AF when instance starts because plog overflow
Posted in 2014
Hello
I have a 11.70FC4 instance that fails to start because of physical log
shortage, here is the extract from online.log :
04:44:38 Logical Recovery has reached the transaction cleanup phase.
04:44:38 Performance Advisory: The physical log is running out of room during
checkpoint processing.
04:44:38 Results: Transactions are being blocked until the checkpoint is
complete.
04:44:38 Action: Increase the physical log size.
04:44:38 Assert Failed: Physical log file overflow
04:44:38 IBM Informix Dynamic Server Version 11.70.FC4
04:44:38 Who: Session(1, informix@afb02, 0, 700000361f00028)
Thread(7, main_loop(), 700000361ebe028, 1)
File: rsbuff.c Line: 4016
04:44:38 Results: Dynamic Server must abort
04:44:38 Action: Reinitialize shared memory
04:44:38 stack trace for pid 15007744 written to
/appli/informix/IDS11.70/tmp/af.3efa5a4
04:44:38 See Also: /appli/informix/IDS11.70/tmp/af.3efa5a4, shmem.3efa5a4.0
As the instance doesn't start, I can't increase the physical log size...
I also have set the PLOG_OVERFLOW_PATH config parameter but it doesnt help,
for an unknown reason it seems that this parameter is ignored because I cannot
see any new file created inside the directory.
I have even tried to start in fast recovery mode using the "oninit -PHY"
undocumented command but then I can't run onparams to increase the plog size
as the command returns "shared memory not initialized" ...
Does anyone have some clue to make this instance start again or do I have only
the option to restore from a previous backup ???
Thanks in advance
Fabrice