Posting from the Informix-list
Posted in 1998
Hi Everybody,
I am not sure what is happning and when my system will go into long
transaction or when it will stop working due to logical log full....
When I give the command ontape -c I get the error message ....
c:>users\\all_load\\err>ontape -c
Performing continuous backup of logical logs.
Please mount tape 1 on E:\\IFMXBKUP\\IFMXBKLG.BAK and press Return to
continue....
Logbackup failed - Logical Log File not found.
This tape contains on log data
Program over.
c:\\Users\\all_load\\err>
Before this the following is what I messed up with :
I was trying to move the logical logs from rootdbs to and newly created
dbspace logdbs
1. Created the logdbs
onspaces -c -d logdbs -p E:\\...\\logdbs.000 -o 0 -s 501000
2. Changed the status to single user mode
onmode -s
3. Added 10 logical logs
onparams -a -d logdbs -s 50000 (ten times)
4. Dropped the free logs
onparams -d -l 1 (2,3,7,8,9,10)
5. Taken level 0 backup
6. Dropped the log number 4.
7. Tried to start the contineous backup
Ontape -c
AND IT GAVE ME THE SAME ERROR ....
"Logbackup failed - Logical Log File not found."
The status of the log at that time was as follows :
INFORMIX-OnLine Version 7.23.TC1 -- On-Line -- Up 2 days 16:55:32 --
103232 Kbytes
Physical Logging
Buffer bufused bufsize numpages numwrits pages/io
P-1 0 16 425 30 14.17
phybegin physize phypos phyused %used
10003f 750 417 0 0.00
Logical Logging
Buffer bufused bufsize numrecs numpages numwrits recs/pages pages/io
L-2 0 16 123461 1958 142 63.1 13.8
address number flags uniqid begin size used %used
cc8355c 5 U-B-C-L 1666 600003 12500 1977 15.82
cc83578 6 U-B-C-- 1657 c00003 12500 8821 70.57
cc83604 11 F------ 0 1300035 12500 0 0.00
cc83620 12 F------ 0 1303109 12500 0 0.00
cc8363c 13 F------ 0 13061dd 12500 0 0.00
cc83658 14 F------ 0 13092b1 12500 0 0.00
cc83674 15 F------ 0 130c385 12500 0 0.00
cc83690 16 F------ 0 130f459 12500 0 0.00
cc836ac 17 F------ 0 131252d 12500 0 0.00
cc836c8 18 F------ 0 1315601 12500 0 0.00
cc836e4 19 F------ 0 13186d5 12500 0 0.00
cc83700 20 F------ 0 131b7a9 12500 0 0.00
I was not sure what to do, so I tried to put more logical logs in the
root dbspace as original and drop the new logs (thinking I might have
made some mistake in the process)
8. I added two more logs in rootdbspace (onparams...)
9. Dropped all the previously added logs....
10. And tried to take a contineous backup, but the status still remains
the same.
11. The current status of logical logs is as follows :
INFORMIX-OnLine Version 7.23.TC1 -- On-Line -- Up 00:23:07 -- 103232
Kbytes
Physical Logging
Buffer bufused bufsize numpages numwrits pages/io
P-1 0 16 0 0 0.00
phybegin physize phypos phyused %used
10003f 750 460 0 0.00
Logical Logging
Buffer bufused bufsize numrecs numpages numwrits recs/pages pages/io
L-2 0 16 1 1 1 1.0 1.0
address number flags uniqid begin size used %used
cc834ec 1 F------ 0 c030d7 12500 0 0.00
cc83508 2 F------ 0 c061ab 12500 0 0.00
cc8355c 5 U-B-C-L 1666 600003 12500 3194 25.55
cc83578 6 U-B-C-- 1657 c00003 12500 8821 70.57
Sorry for giving all the above detailed information as I am not sure
which one will help you to solve my problem.
I will be checking my mails every 10 minutes to see if I have got any
solutions.
Thanks,
Sunil.
PS : I am using informix 7.23 and NT 4.0
______________________________________________________
Get Your Private, Free Email at http://www.hotmail.com