Hi Nuno.
Try the following.(My machine is Solaris)
% /usr/ucb/ps -auxxxxxxxxxxxwwwwwwwwwwwwwwweeeeeeeeee | grep oninit
You can see INFORMIXDIR,INFORMIXSERVER, ONCONFIG (if you specified.) and
etc.
Then
export INFORMIXDIR
export PATH
export INFORIMXSERVER
If you specify, execute export command.
export ONCONFIG
export INFORMIXSQLHOSTS
export CLIENT_LOCALE
export SERVER_LOCALE
export DB_LOCALE
HTH.
--
Tsutomu Ogiwara from Tokyo Japan.
ICQ#:168106592
>From: Nuno Paquete <nmp@ispgaya.pt>
>Reply-To: nmp@ispgaya.pt
>To: informix-list@iiug.org
>Subject: Multiple informix installations.
>Date: Tue, 08 Feb 2005 16:28:04 +0000
>
>Hi group,
>
>I'm starting administering an AIX (Unix) server with informix installed on
>it. I need to access the informix database because I have to make a new
>program that should use the same database, so that all the data inserted
>before could be used.
>The problem is that I found multiple installations of informix and I can't
>run the standard commands (onstat, oninit, etc) in anyone.
>I've got 5 informix directories at the the root (/):
>- OKinformix
>- INFORMIXTMP
>- informix
>- oldinformix
>- sdkinformix
>
>How do I know what installation is??
>I go to the bin directory of all of them but when I try to run "./onstat" I
>receive this error:
>GLS initialization failed, error -23101
>I know that the database is running but I can't find where!!
>What could be the problem? Can anyone help me?
>
>Best regards,
>Nuno Paquete
sending to informix-list