onstat: Changing data structure...
Posted in 1999
Topics: Error Codes & Troubleshooting, Platform-Specific Issues
We are developing a Client-Server application:
Server: SOLARIS with INFORMIX-OnLine Version 7.13.UC2
Client: Windows-Clients with Centura Team Developer application
Problem:
If someone connects to the database using the client application, the
commands
"onstat" and "onstat -g ses" produce the error message:
"Changing data structure forced command termination." and the error code
1.
The command "onstat -g sql" works fine.
Any suggestions?
CU
Robert
In article <36A73AA1.DF0A5917@debis.com>, Robert Schmittinger <robert.sc
hmittinger@debis.com> writes
>We are developing a Client-Server application:
>Server: SOLARIS with INFORMIX-OnLine Version 7.13.UC2
>Client: Windows-Clients with Centura Team Developer application
>
>Problem:
>If someone connects to the database using the client application, the
>commands
>"onstat" and "onstat -g ses" produce the error message:
>"Changing data structure forced command termination." and the error code
>1.
>
Known problem, check the hostname is not >8 characters in length.
Also consider upgrading to 7.30.UC6.
>The command "onstat -g sql" works fine.
>
>Any suggestions?
>
>CU
>Robert
>
>
--
David Williams
Robert Schmittinger wrote:
> We are developing a Client-Server application:
> Server: SOLARIS with INFORMIX-OnLine Version 7.13.UC2
> Client: Windows-Clients with Centura Team Developer application
>
> Problem:
> If someone connects to the database using the client application, the
> commands
> "onstat" and "onstat -g ses" produce the error message:
> "Changing data structure forced command termination." and the error code
> 1.
>
> The command "onstat -g sql" works fine.
>
> Any suggestions?
>
> CU
> Robert
This message appears when one of session' tty name (i.e. Window's computer
name)
is longer than 8 characters
Leonid
This may or may not be a problem. This message is actually displayed by onstat
as the result of the SEGV signal handler in onstat. Since we don't lock all of
the memory in the shared memory segments when the onstat command is being run,
we might run into a SEGV while running through linked lists and such. There
have been real problems with onstat in the past that caused this error as well.
Why are you still on 7.13? While I can understand some hesitation for changing
levels of the engine, I'm a suprised that anyone would still be on 7.1x with
the year 2000 just arround the corner. The first part of the year 2K problem
was implemented in 7.2 with the DBCENTURY parameter.
>We are developing a Client-Server application:
>Server: SOLARIS with INFORMIX-OnLine Version 7.13.UC2
>Client: Windows-Clients with Centura Team Developer application
>
>Problem:
>If someone connects to the database using the client application, the
>commands
>"onstat" and "onstat -g ses" produce the error message:
>"Changing data structure forced command termination." and the error code
>1.
>
>The command "onstat -g sql" works fine.
>
>Any suggestions?
>
>CU
>Robert
Madison Pruet
For most UNIX versions, you need to be at either 7.24.UC7 or 7.30.UC7 to be Y2K complaint. See the following web page for exact information: http://www.informix.com/informix/products/year2000/table1.htm Take care. Clifton >Why are you still on 7.13? While I can understand some hesitation for changing >levels of the engine, I'm a suprised that anyone would still be on 7.1x with >the year 2000 just arround the corner. The first part of the year 2K problem >was implemented in 7.2 with the DBCENTURY parameter.
Related threads
- Posting from the Informix-list
- Migrating from IDS 9.40.UC6 to 11.50.UC3
- Ip for a network session
- questions onstat -g