KAIO on HP-UX and Online 7.23
Posted in 1997
I have been doing some performance tests using KAIO on a dual
processor HP K410 machine running HP-UX 10.20 and Online 7.23.
The tests included trying the two versions of KAIO available with
HP-UX. The choice is made by setting env. variable
IFMX_HPKAIO_VER to either 1 or 2 (2 is the default for HP-UX
10.10 and above). Using IFMX_HPKAIO_VER=2 we got poor through
put, but with IFMX_HPKAIO_VER=1 we were getting approx. 20%
improvement over using AIO vps. However, we have had 2 cases
where the server drops all connections. The server can then only
be recovered by switching off and rebooting/recovering. When this
happens it occurs when you type oninit. This appears problem
appears to be unknown to Informix. There are no messages written
to the online log when it fails this way. I'd be interested to
hear from anyone else who's seen anything like this on HP-UX.
\