Re: Locked record
Posted in 1998
In article <6s36ah$fbr$1@news.xmission.com>,
marek.miloszewski@zes.szczecin.pl (Marek Miloszewski) wrote:
>
> Hi all,
>
> we have a problem with one of our application. Sometimes when somebody
> is
> inserting new record into one of the tables, other person has a problem
> with
> entering the application. Here is a message displayed:
>
> Program stopped at "function.4gl", line number 166.
> SQL statement error number -244.
> Could not do a physical-order read to fetch next row.
> SYSTEM error number -107.
> ISAM error: record is locked.>
> The problem is that it does not happened continuously. One day yes,
> another
> not. Our application producer said this is problem with our Informix
> configuration. But other programs work properly! I don't know were to
> look
> for error...
>
> Any suggestions?
>
Bollocks, the mostly likely cause is the application vendor does not how
to write multi-user systems.
Find out what isolation level you are using,
What lock mode you are using
Is it possible for users to hold exclusive locks for considerable periods
of time ie over 5 seconds.
Paul Watson # I don't suffer from
WF Software Ltd. # stress, I'm just
Tel. (+44) 1436 674729 # a carrier
Fax. (+44) 1436 678693 #