Se Engine Problem ( Systables )
Posted in 1999
Topics: General Discussion
Hi, A little problem here ... ;-) Using an SE Engine on Alpha 4.0D. In systables there is an entry for example xtable which has a directory path pointing to the proper data file ... in the *.dbs directory. This file does exist with data in it. When trying to access the table (with full permissions on the the file) it says it can't be found. Running secheck does not seem to prevent the error. With this said, there is an entry in the systables table with the proper information located in it. Permissions, and the like I have tried ... but does not seem to work. Any ideas? TIA, Lloyd.
In article <smKa4.2502$B3.9794505@news.magma.ca>, "Lloyd AJ Wilson" <lwilson@harriscomputer.com> wrote: > Hi, > > A little problem here ... ;-) > > Using an SE Engine on Alpha 4.0D. In systables there is an entry for > example xtable which has a directory path pointing to the proper data file > ... in the *.dbs directory. This file does exist with data in it. > > When trying to access the table (with full permissions on the the file) it > says it can't be found. Running secheck does not seem to prevent the error. > With this said, there is an entry in the systables table with the proper > information located in it. Permissions, and the like I have tried ... but > does not seem to work. > > Any ideas? > > TIA, > > Lloyd. > > Make sure the owner on the file is the same as the owner in systables. -- # unrm / ksh: unrm: not found # man cpio Sent via Deja.com http://www.deja.com/ Before you buy.
Follow up to post, I have managed to resolve the issue. The problem was that some nucklehead had deleted all the .idx files ... you usually don't think of this .. but I guess there are people out there that are determined to make life misserable for us DBA's and Developers ;-) I just did a restore and ran an update stats. which worked fine. They are now up and running without a problem. Lloyd AJ Wilson. "Lloyd AJ Wilson" <lwilson@harriscomputer.com> wrote in message news:smKa4.2502$B3.9794505@news.magma.ca... > Hi, > > A little problem here ... ;-) > > Using an SE Engine on Alpha 4.0D. In systables there is an entry for > example xtable which has a directory path pointing to the proper data file > ... in the *.dbs directory. This file does exist with data in it. > > When trying to access the table (with full permissions on the the file) it > says it can't be found. Running secheck does not seem to prevent the error. > With this said, there is an entry in the systables table with the proper > information located in it. Permissions, and the like I have tried ... but > does not seem to work. > > Any ideas? > > TIA, > > Lloyd. > >