Server Groups and impact on /etc/services (tcp)
Posted in 2005
Hi people. (Running IDS 9.40 FC6) I am currently configuring a new server with a large number of users. For this we have several DBSERVERALIASES. In the sqlhosts file I have defined a group for this. Now I would like to have each alias connect thru it's own service (in /etc/services) with it's own port (e.g. server1 1050/tcp server2/1051 etc). All server are in the same group. What I do not know (and currently can not test) is if this works. So if 'a' user tries to connect to server1 thru tcp port 1050 and that fails, will the server then automaitically fail over to server2 on port 1051/tcp etc or does the client has to re-enter the connection with another port number? What actually happens when all servers in the group are unavailable? Will it try again or give a ' can not connect' at the end of the (1st) run thru the list? [snip of sqlhosts] servergrp1 group - - e=server3 server1 onipcshm host1 service1 g=servergrp1,k=1 server2 onsoctcp host1 service2 g=servergrp1,k=1 server3 onsoctcp host1 service3 g=servergrp1,k=1 [end snip] [snip /etc/services] service1 1050/tcp service2 1051/tcp service3 1052/tcp [end snip] Thanks, Robert A. Reissaus UBS Swityerland robert.reissaus@ubs.com r.a.reissaus@risdi.com