RE: Stored Procs + SQLWindows
Posted in 1998
We have similar problem with the aplication in Centura 1.1.0 and procedures - Informix WGS 7.12, 7.22, 7.30 our programmers sorted it out this way: -- in application=20 begin work=20 execute procedure ... commit work --- -- in procedure=20 create procedure ... ...=20 commit work begin work set ... .... commit work .... begin work end procedure --- we found out that executing procedure outside the transaction is impossible It looks strange but it works katarina > -----Original Message----- > From: Angelika Draheim [SMTP:draheim@commerzleasing.de] > Sent: Wednesday, December 16, 1998 9:01 PM > To: informix-list@iiug.org > Subject: Stored Procs + SQLWindows >=20 > Does anybody have experience in Informix ODS 7.13 stored procedures > that > are called from a client-programme (Gupta SQLWindows 5.0.4) via Inet? > The procedure deletes records and then inserts new records in the = same > table. This should be possible for multiple users at the same time - > so > we set the lock mode to wait with commited read in the client > application before the stored procedure call is executed. After the > call > is executed, the application calls a commit. Now the problem: A > runtime > error 'already in transaction' occurs when the application is run > including 'set lock mode' and 'begin work / commit work' statements = in > the stored procedure. Running the application with 'commit work' in > the > stored proc leads to runtime error 'not in transaction'. Without > transaction handling at all in the stored proc, the lock mode and > transaction handling in the application seem to be ignored during the > stored proc execution: an isam-error comes up if several users run = the > application and delete at the same time. > When running the stored procedure in DBACCESS including 'set lock > mode' > and 'begin work / commit work' statements everything works fine. > Any help is appreciated! >=20 > Angelika Draheim > CommerzLeasing und Immobilien GmbH > D=FCsseldorf > Germany