IDS Windows Service problem
Posted in 2011
Neil ran IDS 11.7 as a Windows service on XP under a local 'informix' account; after most reboots the service failed to start, apparently having 'forgotten' the password, and re-entering it let it start manually until next reboot. The event log showed "user has not been granted the requested logon type at this computer." Joerg Volz first suspected password policies or antivirus timeouts (both ruled out), then concluded the informix account was losing the "Log on as a service" right, pointing to Microsoft KB 259733. No confirmation from the poster that this fixed it is recorded.
Auto-generated by DrWatson from the posts below — may be imperfect; read the full thread.
Topics: Installation, Setup & Upgrades, Security, Permissions & Auditing
I have IDS 11.7 installed on a test machine for app. development purposes. The IDS instance is a Windows service set to start automatically, and log in with a specific user account (as opposed to the Local System account). When the service is running this IDS instance works as expected. However, when the machine is rebooted the service more often than not will not start automatically . The reason it will not start is that since the previous restart it has 'forgetten' the login account password. Once this is re-entered I can start the service manually and all is then well - until the next time it happens. Is this an IDS issue or a general issue with Windows Services? I can't say I've experienced it before with other service applications. TIA Neil.
Sounds like a windows problem. Check for password policies and especially "user has to change password at first login" or regular password changes. Had this problem once, no login possible while Windows was waiting for the service to change a password. regards Joerg Volz ------------------------------------------------------------------------ ----- -----Original Message----- From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of NEIL HAUGHTON Sent: Friday, July 22, 2011 4:16 PM To: ids@iiug.org Subject: IDS Windows Service problem [24439] I have IDS 11.7 installed on a test machine for app. development purposes. The IDS instance is a Windows service set to start automatically, and log in with a specific user account (as opposed to the Local System account). When the service is running this IDS instance works as expected. However, when the machine is rebooted the service more often than not will not start automatically . The reason it will not start is that since the previous restart it has 'forgetten' the login account password. Once this is re-entered I can start the service manually and all is then well - until the next time it happens. Is this an IDS issue or a general issue with Windows Services? I can't say I've experienced it before with other service applications. TIA Neil. ************************************************************************ ******* Forum Note: Use "Reply" to post a response in the discussion forum. IT Handel und Beratung Jorg Volz Bernhard-Fruh-Str. 7 77855 Achern GERMANY Tel: +49 (0)7841-681651 Fax: +49 (0)7841-681654 Mobil: +49 (0)170-2989757 VAT-ID: DE201383541 http://www.it-volz.de
I'll look into that, but it doesn't explain why this is inconsistent. Some mornings it occurs, and some it is okay. Neil.
Any messages in the windows event log? May be some virus scanner taking to much time scanning dbspace files while service starts up and you are running in a timeout? Regards, Joerg Volz ------------------------------------------------------------------------ ----- -----Original Message----- From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of NEIL HAUGHTON Sent: Friday, July 22, 2011 4:46 PM To: ids@iiug.org Subject: Re: RE: IDS Windows Service problem [24441] I'll look into that, but it doesn't explain why this is inconsistent. Some mornings it occurs, and some it is okay. Neil. ************************************************************************ ******* Forum Note: Use "Reply" to post a response in the discussion forum. IT Handel und Beratung Jorg Volz Bernhard-Fruh-Str. 7 77855 Achern GERMANY Tel: +49 (0)7841-681651 Fax: +49 (0)7841-681654 Mobil: +49 (0)170-2989757 VAT-ID: DE201383541 http://www.it-volz.de
Nothing of much use. The only message from the Informix service is : The ol_mat2 service was unable to log on as .\\\\informix with the currently configured password due to the following error: Logon failure: the user has not been granted the requested logon type at this computer. Followed by a second message confirming that the service failed to start. ..both of which only tell me what I already know. If I re-enter the password, the service will successfully start - until next time this happens. .\\\\informix is a local user (not Active Directory), and I've checked in the XP Control Panel but there is no option to enforce (or not) any password policy, or any restrictions on password lifetime. Local user, it seems, have a password and that is that until the user changes it. In any event, I am not being forced to change the password - the 'old' password works perfectly well to start the service. It's just that next time round it has to be manually entered again (and again...). Neil.
No virus scanning - I have switched it off. Neil
Logon failure: the user has not been granted the requested logon type at this computer. Sounds like the User informix has no right to act/login as a service, that is a special right, but to my shame: I don´t know how to give that right to a local Windows user. I think (but don´t bet money on it) that right is given automatically on a "solo" windows box if the useraccount is used as a service user. Regards Joerg Volz ----------------------------------------------------------------------------- -----Original Message----- From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of NEIL HAUGHTON Sent: Monday, July 25, 2011 10:31 AM To: ids@iiug.org Subject: Re: RE: RE: IDS Windows Service problem [24451] Nothing of much use. The only message from the Informix service is : The ol_mat2 service was unable to log on as .\\\\informix with the currently configured password due to the following error: Logon failure: the user has not been granted the requested logon type at this computer. Followed by a second message confirming that the service failed to start. ...both of which only tell me what I already know. If I re-enter the password, the service will successfully start - until next time this happens. ..\\\\informix is a local user (not Active Directory), and I've checked in the XP Control Panel but there is no option to enforce (or not) any password policy, or any restrictions on password lifetime. Local user, it seems, have a password and that is that until the user changes it. In any event, I am not being forced to change the password - the 'old' password works perfectly well to start the service. It's just that next time round it has to be manually entered again (and again...). Neil. ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum. IT Handel und Beratung Jörg Volz Bernhard-Früh-Str. 7 77855 Achern GERMANY Tel: +49 (0)7841-681651 Fax: +49 (0)7841-681654 Mobil: +49 (0)170-2989757 VAT-ID: DE201383541 http://www.it-volz.de
follow up to the MSDN KB: http://support.microsoft.com/kb/259733/en-us regards Jörg Volz --------------------------------------------- ________________________________ Von: ids-bounces@iiug.org im Auftrag von Joerg Volz Gesendet: Mo 25.07.2011 15:00 An: ids@iiug.org Betreff: RE: RE: RE: IDS Windows Service problem [24453] Logon failure: the user has not been granted the requested logon type at this computer. Sounds like the User informix has no right to act/login as a service, that is a special right, but to my shame: I don´t know how to give that right to a local Windows user. I think (but don´t bet money on it) that right is given automatically on a "solo" windows box if the useraccount is used as a service user. Regards Joerg Volz ----------------------------------------------------------------------------- -----Original Message----- From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of NEIL HAUGHTON Sent: Monday, July 25, 2011 10:31 AM To: ids@iiug.org Subject: Re: RE: RE: IDS Windows Service problem [24451] Nothing of much use. The only message from the Informix service is : The ol_mat2 service was unable to log on as .\\\\informix with the currently configured password due to the following error: Logon failure: the user has not been granted the requested logon type at this computer. Followed by a second message confirming that the service failed to start. ....both of which only tell me what I already know. If I re-enter the password, the service will successfully start - until next time this happens. ...\\\\informix is a local user (not Active Directory), and I've checked in the XP Control Panel but there is no option to enforce (or not) any password policy, or any restrictions on password lifetime. Local user, it seems, have a password and that is that until the user changes it. In any event, I am not being forced to change the password - the 'old' password works perfectly well to start the service. It's just that next time round it has to be manually entered again (and again...). Neil. ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum. IT Handel und Beratung Jörg Volz Bernhard-Früh-Str. 7 77855 Achern GERMANY Tel: +49 (0)7841-681651 Fax: +49 (0)7841-681654 Mobil: +49 (0)170-2989757 VAT-ID: DE201383541 http://www.it-volz.de ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.