Re: Onbar Scalability Issues
Posted in 1999
Rick Rabe wrote:
> This message is in MIME format. Since your mail reader does not understand
> this format, some or all of this message may not be legible.
>
> ------_=_NextPart_001_01BECFD0.A496FABC
> Content-Type: text/plain
>
> I'm not familiar with Netbackup, but use Networker on Siemens-Pyramid. My
> BAR_MAX_BACKUP is set to 8. One thing I have found helpful is altering
> bar_action, bar_instance, bar_object in the sysutils database to row-level
> locking instead of page-level locking.
>
> HTH
> rrabe
>
> > ----------
> > From: Steve Hawkins[SMTP:steve.hawkins@orange.co.uk]
> > Reply To: Steve Hawkins
> > Sent: Friday, July 09, 1999 3:38 AM
> > To: informix-list@iiug.org
> > Subject: Onbar Scalability Issues
> >
> > We are currently running informix 7.24 on Solaris 2.5.1 (E10000
> > Platform) and have been using onbar to do backups through to Netbackup.
> > This generally works ok, despite the database being 300Gb of used pages
> > in size, although it does fail with connection timeout errors. The
> > connection timeout errors wouldn't be so bad if the connection to
> > Netbackup was remote but in this case it is all on the same machine
> > along with the backup robot.
> >
> > Also when trying to enable additional onbar's to run by specifiying the
> > dbspaces to backup the error 54's get progressively worse to the point
> > where a good daily backup is un-achievable.
> >
> > Does anyone else use onbar in this way i.e. onbar -b -L 0 <dbspace
> > list>, and changing the onconfig to allow multiple onbar's to run
> > (BAR_MAX_BACKUP 6) ?
> >
> I do it almost exactly this way. I have BAR_MAX_BACKUP set to 12 and the
> same parm in Networker set to 12. I do an onbar -b -L 0 (with no dbspaces
> specified). After the rootdbs is archived, onbar spawns 12 processes and
> keeps 12 going in parallel until all of 53 of my dbspaces are complete.
> Informix 7.30 on Solaris 2.6 and Networker 5.1 to two DLT drives. I archive
> approx 50 gig in 45 minutes.
> Doug...
>
> ------_=_NextPart_001_01BECFD0.A496FABC
> Content-Type: text/html
> Content-Transfer-Encoding: quoted-printable
>
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
> <HTML>
> <HEAD>
> <META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
> charset=3Dus-ascii">
> <META NAME=3D"Generator" CONTENT=3D"MS Exchange Server version =
> 5.5.2448.0">
> <TITLE>RE: Onbar Scalability Issues</TITLE>
> </HEAD>
> <BODY>
>
> <P><FONT COLOR=3D"#0000FF" SIZE=3D2 FACE=3D"Courier New">I'm not =
> familiar with Netbackup, but use Networker on Siemens-Pyramid. My =
> BAR_MAX_BACKUP is set to 8. One thing I have found helpful is altering =
> bar_action, bar_instance, bar_object in the sysutils database to =
> row-level locking instead of page-level locking.</FONT></P>
>
> <P><FONT COLOR=3D"#0000FF" SIZE=3D2 FACE=3D"Courier New">HTH</FONT>
> <BR><FONT COLOR=3D"#0000FF" SIZE=3D2 FACE=3D"Courier New">rrabe</FONT>
> </P>
> <UL>
> <P><FONT SIZE=3D2 FACE=3D"MS Sans Serif">----------</FONT>
> <BR><B><FONT SIZE=3D2 FACE=3D"MS Sans Serif">From:</FONT></B> =
> <FONT SIZE=3D2 FACE=3D"MS Sans Serif">Steve =
> Hawkins[SMTP:steve.hawkins@orange.co.uk]</FONT>
> <BR><B><FONT SIZE=3D2 FACE=3D"MS Sans Serif">Reply To:</FONT></B> =
> <FONT SIZE=3D2 FACE=3D"MS Sans =
> Serif">Steve Hawkins</FONT>
> <BR><B><FONT SIZE=3D2 FACE=3D"MS Sans Serif">Sent:</FONT></B> =
> <FONT SIZE=3D2 FACE=3D"MS Sans Serif">Friday, July 09, 1999 3:38 =
> AM</FONT>
> <BR><B><FONT SIZE=3D2 FACE=3D"MS Sans Serif">To:</FONT></B> =
> <FONT SIZE=3D2 FACE=3D"MS Sans =
> Serif">informix-list@iiug.org</FONT>
> <BR><B><FONT SIZE=3D2 FACE=3D"MS Sans Serif">Subject:</FONT></B> =
> <FONT SIZE=3D2 FACE=3D"MS Sans =
> Serif">Onbar Scalability Issues</FONT>
> </P>
>
> <P><FONT SIZE=3D2 FACE=3D"Arial">We are currently running informix 7.24 =
> on Solaris 2.5.1 (E10000</FONT>
> <BR><FONT SIZE=3D2 FACE=3D"Arial">Platform) and have been using onbar =
> to do backups through to Netbackup.</FONT>
> <BR><FONT SIZE=3D2 FACE=3D"Arial">This generally works ok, despite the =
> database being 300Gb of used pages</FONT>
> <BR><FONT SIZE=3D2 FACE=3D"Arial">in size, although it does fail with =
> connection timeout errors. The</FONT>
> <BR><FONT SIZE=3D2 FACE=3D"Arial">connection timeout errors wouldn't be =
> so bad if the connection to</FONT>
> <BR><FONT SIZE=3D2 FACE=3D"Arial">Netbackup was remote but in this case =
> it is all on the same machine</FONT>
> <BR><FONT SIZE=3D2 FACE=3D"Arial">along with the backup robot.</FONT>
> </P>
>
> <P><FONT SIZE=3D2 FACE=3D"Arial">Also when trying to enable additional =
> onbar's to run by specifiying the</FONT>
> <BR><FONT SIZE=3D2 FACE=3D"Arial">dbspaces to backup the error 54's get =
> progressively worse to the point</FONT>
> <BR><FONT SIZE=3D2 FACE=3D"Arial">where a good daily backup is =
> un-achievable.</FONT>
> </P>
>
> <P><FONT SIZE=3D2 FACE=3D"Arial">Does anyone else use onbar in this way =
> i.e. onbar -b -L 0 <dbspace</FONT>
> <BR><FONT SIZE=3D2 FACE=3D"Arial">list>, and changing the onconfig =
> to allow multiple onbar's to run</FONT>
> <BR><FONT SIZE=3D2 FACE=3D"Arial">(BAR_MAX_BACKUP 6) ?</FONT>
> </P>
> </UL>
> </BODY>
> </HTML>
> ------_=_NextPart_001_01BECFD0.A496FABC--