Re: unix odbc and informix datasource problem
Posted in 2006
Topics: Connectivity: ODBC / JDBC / .NET
>> What version of unix ODBC DM are you using? Is it >= 2.2.11?
> Yes it is
We are using 2.2.11-19 without incident.
> As enough
>> error message is not provided...Are you getting something of "ERROR
>> -11048: UNABLE TO LOAD TRANSLATION SHARED LIBRARY (DLL)" ..> No, there IS no error message. Just what I posted.
Did you try doing an isql -v {DSN} to see if you get more info.
For instance:
tyr:~ # isql miecr
[ISQL]ERROR: Could not SQLConnect
tyr:~ # isql -v miecr
[S1000][unixODBC][Informix][Informix ODBC Driver][Informix]Client host
or user root@TYR.morrison.iserv.net is not trusted by the server.
[ISQL]ERROR: Could not SQLConnect
> Did you try doing an isql -v {DSN} to see if you get more info. > then I get: [unixODBC][Informix][Informix ODBC Driver]Data source name not found and no default driver specified. [ISQL]ERROR: Could not SQLConnect [root@kylie bin]#
On Wed, 2006-07-19 at 08:34 -0700, kjuliff@gmail.com wrote: > > Did you try doing an isql -v {DSN} to see if you get more info. > then I get: > [unixODBC][Informix][Informix ODBC Driver]Data source name not found > and > no default driver specified. > [ISQL]ERROR: Could not SQLConnect Then I suspect you don't have the ODBCINI environment variable specified correctly.
Now I get [unixODBC][Informix][Informix ODBC Driver][Informix]Server kylie is not l isted as a dbserver name in sqlhosts And I have ensured there are no white spaces in odbc.ini or odbcinst.ini
Getting better. Now it's only Client host or user root@localhost.localdomain is not trusted by the server.