Error -23101
Posted in 1999
Topics: Storage & Space Management, Internationalization & Character Sets
I get the following error when trying to connect to an informix database using Informix on Windows NT. [Informix][sqlinfmx.dll]SQL Error [-23101] Unable to load locale categories. The problem was, after I modified to value of the column "site" of the row GL_COLLATE and GL_CTYPE of the systable of the database that, now, I can't open correctly. Can anyone help me with this trouble? I want to drop the unique table that this database contain, but the previous message appear, I can't drop the database, and the worst I can't delete the dbspace! Please answer me althougt the answer will be very easy. Thank you for your help. Luis.
DPCATAS wrote: > I get the following error when trying to connect to an informix > database > using > Informix on Windows NT. > > [Informix][sqlinfmx.dll]SQL Error [-23101] Unable to load locale > categories. > > The problem was, after I modified to value of the column "site" of > the > row > GL_COLLATE and GL_CTYPE of the systable of the database that, now, I > can't > open correctly. > > Can anyone help me with this trouble? > I want to drop the unique table that this database contain, but the > previous message > appear, I can't drop the database, and the worst I can't delete the > dbspace! > > Please answer me althougt the answer will be very easy. > Thank you for your help. > > Luis. Have you set CLIENT_LOCAL ? When, it is correct? --
Prounix GmbH wrote: > DPCATAS wrote: > > > I get the following error when trying to connect to an informix > > database > > using > > Informix on Windows NT. > > > > [Informix][sqlinfmx.dll]SQL Error [-23101] Unable to load locale > > categories. > > > > The problem was, after I modified to value of the column "site" of > > the > > row > > GL_COLLATE and GL_CTYPE of the systable of the database that, now, I > > can't > > open correctly. > > > > Can anyone help me with this trouble? > > I want to drop the unique table that this database contain, but the > > previous message > > appear, I can't drop the database, and the worst I can't delete the > > dbspace! > > > > Please answer me althougt the answer will be very easy. > > Thank you for your help. > > > > Luis. > > Have you set CLIENT_LOCAL ? It should be CLIENT_LOCALE > > When, it is correct? > > -- I am not sure if it is a good thing to change values in the systables. I have the impresssion that Informix stores some information also in not accessible areas - and this information might conflict with changed informations in systables. Regards -- Helmut Leininger Bull AG / Vienna Unix Support Email: h.leininger@bull.at helmut.leininger@bull.net This opinion is mine and not necessarily that of my employer. No guarantees whatsoever.