Problem with ECC install
Posted in 2005
I installed
enterprise command center (ECC) so I can configure and run high performance
loader (HPL). The install worked without any errors but I am having problems
connecting into the database with the console. I can click on spaces, errors,
reports, bar activity, and sessions without any errors, but when I try to
click on the database I recieve an error that the database is not in the
sqlhosts file. It is and I can connect to the data base with other Informix
CSDK tools like SQL Editor 3.01 table editor 3.01.
I know that the issue has to do with the server alias. I connect to the server
fine using onsoctcp to the alias dev_tcp. ECC automatically picks up the
server name of dev_shm and tries to connect to that even though it is an
internal connection.
The server is on AIX 4.3
The IDS is 7.31.UC5
The desktop with ECC installed is Windows 2000 V5.0 build 2195 SP4
the ECC is 3.01 TC1
I have started the service agent with:
startsa
I have used setnet32 to configure the server as follows:
Informix server = dev_tcp
Host name = infmx_test
Protocol name = onsoctcp
Service name = sqlexec7
the onconfig is below for the server:
# System Configuration
SERVERNUM 5 # Unique id corresponding to a OnLine instance
DBSERVERNAME dev_shm # Name of default database server
DBSERVERALIASES dev_tcp # List of alternate dbservernames
NETTYPE ipcshm,1,10,CPU # Configure poll thread(s) for nettype
NETTYPE soctcp,1,10,NET # Configure poll thread(s) for nettype
the sqlhosts file in /informix/etc has the following lines:
dev_shm onipcshm infmx_test sqlexec6
dev_tcp onsoctcp infmx_test sqlexec7
The services file on the unix server has the following lines:
sqlexec6 1529/tcp
sqlexec7 1530/tcp
The problem is that everytime I start ECC on the desk top is does an automatic
connection to dev_shm (the unix connection) instead of dev_tcp the tcp
connection.
I have removed dev_shm from Setnet32 and I am now stumped as to how to get ECC
to connect to dev_tcp instead of dev_shm.
the message I get when I try to connect to the database from the database
folder on ECC is as follows:
"Unable to access this machine through the network at this time. Verify that
the machine is on and is listed in your host files. The NT host file is
located at /%systemroot%/system32/drivers/etc/hosts."
The hosts file on the desktop in c:\\\\WINNT\\\\system32\\\\drivers\\\\etcis as follows:
xx.xx.xxx.xxx infmx_test
Sorry for long post, but I am just stuck and don't know what to look at next.
I know that I need to connect to "dev_tcp" and not "dev_shm" but I can not get
ECC to do that.