java.io.IOException in Installshied for client SDK
Posted in 2009
Topics: Installation, Setup & Upgrades, Platform-Specific Issues, Java & JDBC Development
I am getting the following error on installing 3.5 client SDK On Solaris 10 Initializing InstallShield Wizard........ Launching InstallShield Wizard........ java.io.IOException: Not enough space at java.lang.UNIXProcess.forkAndExec(Native Method) at java.lang.UNIXProcess.<init>(UNIXProcess.java:53) at java.lang.ProcessImpl.start(ProcessImpl.java:65) at java.lang.ProcessBuilder.start(ProcessBuilder.java:451) at java.lang.Runtime.exec(Runtime.java:591) at java.lang.Runtime.exec(Runtime.java:464) If I ignore the error (the script seems to carry on running) I then get WARNING: /app/dnyoptxm01/informix has insufficient space to install the items selected. 140.2 MB additional space would be needed to install the selected items. ---------------------------------- However both errors appear bogus as there are very few processes running on the server and there is 93G free on the filesystem. Very strange! Any insights through the ether?
Probably the TMPDIR filesystem is filling and the error message specifying INFORMIXDIR as the FS that's filling up is bogus. Art Art S. Kagel Oninit (www.oninit.com) IIUG Board of Directors (art@iiug.org) Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on my employer, Oninit, the IIUG, nor any other organization with which I am associated either explicitly or implicitly. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Mon, Aug 17, 2009 at 3:16 PM, TONY HORSWILL < tony.horswill@credit-suisse.com> wrote: > I am getting the following error on installing 3.5 client SDK On Solaris 10 > > Initializing InstallShield Wizard........ > > Launching InstallShield Wizard........ > > java.io.IOException: Not enough space > > at java.lang.UNIXProcess.forkAndExec(Native Method) > > at java.lang.UNIXProcess.<init>(UNIXProcess.java:53) > > at java.lang.ProcessImpl.start(ProcessImpl.java:65) > > at java.lang.ProcessBuilder.start(ProcessBuilder.java:451) > > at java.lang.Runtime.exec(Runtime.java:591) > > at java.lang.Runtime.exec(Runtime.java:464) > > If I ignore the error (the script seems to carry on running) I then get > > WARNING: /app/dnyoptxm01/informix has insufficient space to install the > items > selected. 140.2 MB additional space would be needed to install the selected > items. > ---------------------------------- > However both errors appear bogus as there are very few processes running on > the server and there is 93G free on the filesystem. Very strange! > > Any insights through the ether? > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --0023545306684fad2504715ba1f4
Hi Art, Thanks. I have tried modifying TMPDIR and -tempdir so far without success but it has got me looking at the install script for clues. Regards, Tony
This problem was fixed by installing the Java that came as part of the tar package. This was interesting in that this Java was 1.49 and the failing version was later (1.50)