How to release the lock of database?
Posted in 1999
Hi, All,
I have problems to access the database....
I think this problem happens because i tried to install DBD-Informix
which accessed the demo database but it does not exist on my server.
Before that action, it works well. So I think my environment variable
is all set.(including INFORMIXDIR , INFORMIXSERVER, DBPATH....)
And after that the problem happens!!! I tried to use " ps -aux" to see
which process is run away and kill it, but it didn't work.
Then i reinstalled the Redhat Linux 6.0, Informix SE , ISQL,
ESQL/C,etc. and when i use "isql"(the same as dbaccess) to create(or select)
database, it answers me the error message:
908: try to connect to the database server (dbs_rm) failed.
ISAM Error: the record has been locked.
p.s. "dbs_rm" is my INFORMIXSERVER name.
my /home/informix/etc/sqlhosts : dbs_rm sesoctcp dbserver
dbs_services
I add " dbs_services 8888/tcp" to my /etc/services
I don't know how to release the lock....
Thank you for your help .....