Re: Tripping Server - Last Gasp
Posted in 1993
>Date: Wed, 24 Feb 93 12:13:06 +0800
>From: Richard Ridley <uunet!sin-pss.DHL.COM!rridley>
>Subject: Tripping Server - Last Gasp
>X-Informix-List-Id: <list.1929>
>I posted a query on this problem a while back but there wasn't too
>much of a response so here goes again. Our local Informix support
>told us that this problem was bug number 12566 and was fixed in
>I-Star Ver 4.10.UE5 and later versions. We have tested it using
>Online 4.10.UG1 and I-Star 4.10.UG1 and (surprise, surprise!) the
>problem is still happening. They have now decided that it isn't that
>bug after all and have ridden off on a mystery tour that has lasted
>over a week now, with no visible results.
>The problem is fairly easy to duplicate, as the code below will show:
>Is there anyone out there (Someone from Informix perhaps?) who can
>test this and tell us exactly which versions to avoid ? This is very
>important to us as one of our major applications depends on this
>piece of code working.
>The Error message:
>SQL statement error number -211
>Cannot read system catalog (systables).
>System error number -101.
>ISAM error: file is not open.
It may not be want you wanted to hear, but I tested your code on a Sun
running SunOS 4.1.3 with OnLine 5.01.UC1A2, I4GL-RDS 4.10.UC1 and I4GL-ID
4.10.UC1. I don't have a running OnLine 4.10 system at hand.
The two databases I used were part of the same OnLine system because your
example did not show any need for I-Star -- your remote table would have to
be referred to as other_db@other_site:table to need I-Star.
Once I'd chosen two databases with the same logging mode, and corrected the
code (which uses temp1_exists but declares tab1_exists), the program worked
correctly first time.
Since your message suggests I-Star is the cause of the trouble, would you
care to re-frame your problem in terms of what you are really suffering
from, or is it that the Version 5 engine doesn't suffer from the problem?
If you revise your example, I suggest you use column tabname from table
systables (and perhaps colname from syscolumns for the second query), so
the only change I have to make is to the names of the databases I use, and
the system name if necessary.
Yours,
Jonathan Leffler (johnl@obelix.informix.com) #include <disclaimer.h>