Re: Update failed question
Posted in 1995
In article <3m1oo3$1a4@cssun.mathcs.emory.edu> nnob@loc.gov "Nick Nobbe" writes: > Just as a point of interest, using SE 5.x, I discovered that using exclusive > mode caused some of our long update/insert transactions to halt before > completion. Changing to share mode solved the problem. I don't know > exactly why, but my guess is share seems to be locking and releasing > locks on a record by record basis. Versions prior to 5.02 have a bug in that 'LOCK table IN EXCLUSIVE MODE' should use 1 UNIX lock, but actually uses 1 per row. But why changing to SHARE mode should cure the above is a mystery 8-}! -- ============================================================================ Sally Woolrich | This mail contains my personal sally@excelsis.demon.co.uk | views not those of my employer! ============================================================================