cannot run dbschema
Posted in 1999
Topics: General Discussion
I am unable to run dbschema on a selected database, even though I
login to the NT workstation as user "informix." User informix is a
member of the Informix-Admin group. When I issue the dbschema command
I get error 956 (client or user "login_user@my_machine_name.domain"
not trusted by the server.) How do I get around it?
Also, how can I create new user accounts on the Informix server? The
documentation really lacks in this respect, or it's very hard to find.
Thanks in advance for all your help
hskora@nmcourt.fed.us wrote:
> I am unable to run dbschema on a selected database, even though I
> login to the NT workstation as user "informix." User informix is a
> member of the Informix-Admin group. When I issue the dbschema command
> I get error 956 (client or user "login_user@my_machine_name.domain"
> not trusted by the server.) How do I get around it?
> Also, how can I create new user accounts on the Informix server? The
> documentation really lacks in this respect, or it's very hard to find.
> Thanks in advance for all your help
Hi,
I do not quite understand your problem. What do you mean by "login as user
informix"? Does it mean that you are coming from another computer with
informix?
I once had the folloeing problem:
- Database installed on NT (Informix OWS)
- Another database with Informix IDS installed on a AIX (Unix) server
- The UNIX server was not trusted for access to the NT-database (via Informix
mechanisms on the AIX machine)
Solution:
I created a file "hosts.equiv" in c:\\Winnt\\system32\\drivers\\etc with an entry
for the AIX system (as I would have done on any UNIX system). It works although
this is not documented anywhere.
Regards
--
Helmut Leininger
Bull AG / Vienna
Unix Support
Email: h.leininger@bull.at
helmut.leininger@bull.net
This opinion is mine and not necessarily that of my employer.
No guarantees whatsoever.
hskora@nmcourt.fed.us wrote:
>
> I am unable to run dbschema on a selected database, even though I
> login to the NT workstation as user "informix." User informix is a
> member of the Informix-Admin group. When I issue the dbschema command
> I get error 956 (client or user "login_user@my_machine_name.domain"
> not trusted by the server.) How do I get around it?
> Also, how can I create new user accounts on the Informix server? The
> documentation really lacks in this respect, or it's very hard to find.
You need to include your workstation in /etc/hosts.equiv or, better from
a security view, in .rhosts file in the informix home directory.
Informix does not maintain it's own user logins, it uses the local
system's login facility/protection. You need to create a user account
on the server's OS, which does not have to be login-able (ie needs no
password unless you will be using the USERNAME PASSWORD options to the
connect verb) but should have a real home directory for writing files
such as sqexplain.out, etc. You then grant the appropriate permissions
on the database/table/column/procedure levels to that user or to
'public' in the database and you are all set.
Art S. Kagel
You have to change the user profile options on the Server (I guess you
have Win NT Server...) The user "informix" profile has to be changed
to be able to use "trusted" connections... I can't remember where the
option is, but it exists on the user management section...
Best regards
On Tue, 19 Jan 1999 17:04:32 -0700, hskora@nmcourt.fed.us wrote:
>
> I am unable to run dbschema on a selected database, even though I
> login to the NT workstation as user "informix." User informix is a
> member of the Informix-Admin group. When I issue the dbschema command
> I get error 956 (client or user "login_user@my_machine_name.domain"
> not trusted by the server.) How do I get around it?
> Also, how can I create new user accounts on the Informix server? The
> documentation really lacks in this respect, or it's very hard to find.
> Thanks in advance for all your help
_____________________________________________________
AtlanticSoftware - Elaboração de Web Pages,
Design Gráfico, Multimédia e programação
de Software à Medida.
WWW: http://members.xoom.com/atlanticsoft
E-Mail: altlanticsoft@xoommail.com
Marco Ascensao (Socio Gerente)
E-Mail: mpfa.madeira@mail.telepac.pt
WWW: http://members.xoom.com/marcomadeira
_____________________________________________________