Deleting Using Rowid
Posted in 2006
Topics: SQL Development & Query Writing, Error Codes & Troubleshooting, Migration, Import/Export & Data Conversion, Platform-Specific Issues
9.21.UC5XF AIX 4.3.3 I have had, over the last three months, the same table
(less than 4k rows) have a problem getting the following error while deleting
using a rowid: SQL statement error number -240. (Could not delete a
row.)SYSTEM error number -126. (ISAM error: bad row id) Unloading and dropping
and recreating the table and loading the data back in fixes the issue ... but
only temporarily it seems as the problem occurred first on April 24 and again
yesterday. Performing an oncheck -cDI against the table reveals no errors.
There is a primary composite key involving three fields on the table. (Yes, I
would have had the primary key be a serial fields myself but I was not here
when the schema was put in place.) Is there a known issue with using rowids
for deletes within this engine? Thanks in advance.Clifton
_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!
Hi,
I have heard of such a problem, but I cannot remember the release.
The point is, that Informix wanted to remove rowid support, because the
storage of a table row was not limited to a continuous space any more when
they allowed alter tables in place (which in case of adding a column would
reserve the space in other free blocks and return immediately and not
reorganize the table in total any more). I think it became worse when they
came up with fragmentation.
Sorry, no more memories about that, we never worked with 9.21, started in
9.30 after 7.31. I think our programs reacted correctly then (also using
row-ids). I cannot remember, but I think there is a parameter or command for
adding correct rowid support using alter table, perhaps you find it in the
manual.
Marcus
-----Original Message-----
From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of
clifbean@ex....
Sent: Friday, June 16, 2006 6:12 PM
To: ids@iiug.org
Subject: Deleting Using Rowid [6969]
9.21.UC5XF AIX 4.3.3 I have had, over the last three months, the same table
(less than 4k rows) have a problem getting the following error while
deleting using a rowid: SQL statement error number -240. (Could not delete a
row.)SYSTEM error number -126. (ISAM error: bad row id) Unloading and
dropping and recreating the table and loading the data back in fixes the
issue ... but only temporarily it seems as the problem occurred first on
April 24 and again yesterday. Performing an oncheck -cDI against the table
reveals no errors.
There is a primary composite key involving three fields on the table. (Yes,
I would have had the primary key be a serial fields myself but I was not
here when the schema was put in place.) Is there a known issue with using
rowids for deletes within this engine? Thanks in advance.Clifton
_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!
****************************************************************************
***
Forum Note: Use "Reply" to post a response in the discussion forum.
Sounds to me like you are having problems with flaky disk subsystem drives. I'd
say it's time to replace all those old drives.
Art S. Kagel
----- Original Message -----
From: Clifbean@Ex.... <ids@iiug.org>
At: 6/16 12:15:42
9.21.UC5XF AIX 4.3.3 I have had, over the last three months, the same table
(less than 4k rows) have a problem getting the following error while deleting
using a rowid: SQL statement error number -240. (Could not delete a
row.)SYSTEM error number -126. (ISAM error: bad row id) Unloading and dropping
and recreating the table and loading the data back in fixes the issue ... but
only temporarily it seems as the problem occurred first on April 24 and again
yesterday. Performing an oncheck -cDI against the table reveals no errors.
There is a primary composite key involving three fields on the table. (Yes, I
would have had the primary key be a serial fields myself but I was not here
when the schema was put in place.) Is there a known issue with using rowids
for deletes within this engine? Thanks in advance.Clifton
_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.
Related threads
- Re(2): Write cache hits slipping !
- same View fails to run under IDS 10
- number of extents
- ONCONFIG file only for server or for informix client