Assert Failed iserr = 124
Posted in 2009
Topics: High Availability & Replication, Error Codes & Troubleshooting
Hi All,
Our IDS v7.31 ud8, which is a HDR secondary pair failed suddenly and was
found in a hung state. I had to recycle the engine to bring it up and now its
running fine.
This has occured second time within last 2 months.
But I could not analyse the reason from af** files. onstat -l, onstat -d ,
onstat -g sql etc does not give a proper reason why it was hung.
Does the first 'who' from the log indicates(?) that its a daemon thread. How
can I analyse it further ?
We donot have tech support.
Can any one help?
online.log
18:50:10 Rollforward of log record failed. iserrno = 124
18:50:10 Log Record: log = 78546, pos = d1c1558, type = OLDRSAM:ADDITEM(28),
trans = 149
18:50:10 Log Record: log = 78546, pos = d1bf0f4, type = OLDRSAM:DELITEM(29),
trans = 990
18:50:10 Assert Failed: No Exception Handler
18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
18:50:10 Who: Session(113, informix@abc, 0, 1129401080)
Thread(255, xchg_1.4, 434eeb54, 13)
File: mtex.c Line: 471
18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
18:50:10 Results: Exception Caught. Type: MT_EX_OS, Context: mem
18:50:10 Exception Recursion while handling: MT_EX_NONE, Context:
18:50:10 Assert Failed: No Exception Handler
18:50:10 Assert Failed: No Exception Handler
18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
18:50:10 Action: Action: %s
18:50:10 Who: Session(113, informix@abc, 0, 1192724196)
Thread(265, xchg_1.14, 434f1d7c, 8)
File: mtex.c Line: 471
18:50:10 Assert Failed: Memory free block header corruption detected in
mt_shm_malloc_segid 1
18:50:10 Assert Failed: No Exception Handler
18:50:10 Results: Exception Caught. Type: MT_EX_OS, Context: mem
18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
18:50:10 Action:
18:50:10 Who: Session(4628044, gtsrep@devrep.sd.avaya.com, 6540, 1129431704)
Thread(4628093, sqlexec, 434f3b94, 1)
File: mtex.c Line: 471
18:50:10 Results: Exception Caught. Type: MT_EX_OS, Context: ill
18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
18:50:10 Who: Session(113, informix@abc, 0, 1129401080)
Thread(260, xchg_1.9, 434f0468, 7)
File: mtex.c Line: 471
18:50:10 Results: Exception Caught. Type: MT_EX_OS, Context: mem
18:50:10 Action: Action: %s
18:50:11 Who: Session(113, informix@abc, 0, 1192724892)
Thread(256, xchg_1.5, 434ef058, 9)
File: mtshpool.c Line: 3006
18:50:11 Results: Unable to repair pool
18:50:11 Action: Please notify IBM Informix Technical Support.
18:50:11 invoke_alarm(): ALRMMALLOC failed: ALRMMALLOC(158)==0
18:50:11 listener-thread: err = -406: oserr = 62: errstr = : Memory allocation
failed.
18:50:20 See Also: /analysis/dump/af.4e8cec2
18:55:12 VP Notify mechanism incomplete after 5 minutes. This can be due to
slow network file access. Will try 12 more times
1
Abbreviated output from AF* files
onstat -u
434ec838 ---P-R-*113 informix - 0 0 0 139 29151880
434ecd3c -----R-*113 informix - 0 0 0 0 0
434ed240 Y----RD*113 informix - 436a0a38 0 0 0 0
434ed744 -----RD*113 informix - 0 0 0 2393713 1508199
434edc48 Y----RD*113 informix - 436a1068 0 0 736291 715176
434ee14c Y----RD*113 informix - 436a1020 0 0 616100 673728
434ee650 Y----RD*113 informix - 436a0fd8 0 0 2079713 1557963
/usr/informix_7.31.ud8/bin/onstat -g ses 113:
*** WARNING: IBM Informix Dynamic Server is no longer running. ***
*** WARNING: IBM Informix Dynamic Server is no longer running. ***
IBM Informix Dynamic Server Version 7.31.UD8 -- Read-Only (Sec) -- Up 22 days
22:14:07 -- 2917680 Kbytes
session #RSAM total used
id user tty pid hostname threads memory memory
*** WARNING: IBM Informix Dynamic Server is no longer running. ***
/onstat -g sts:
255 40448 8306 20 4176 10 xchg_1.4
256 40448 11123 27 7080 17 xchg_1.5
onstat -g stk all
Stack for thread: 255 xchg_1.4base: 0x4407c000
len: 40960
pc: 0x0042e358
tos: 0x44084fb0
state: running
vp: 13
0x0044e620 (oninit)afhandler(0x3, 0x6dddbc, 0x6ddbc0, 0x1, 0x4e7cec2, 0x1)
0x0044e094 (oninit)afcrash_interface(0x69adc0, 0x44085798, 0x6ce19c, 0x69add8,
0x1d7, 0x0)
0x004519c8 (oninit)mt_ex_throw_sig(0x65b400, 0x425c34dc, 0x0, 0x0, 0x0, 0x0)
0x00090d4c (oninit)afsig_segv(0x30303030, 0x30303020, 0x30303030, 0x32303230,
0x20202020, 0x20202020)
0x004474b8 (oninit)print_qhdr(0x0, 0x43b1e03c, 0xfffffffe, 0x7c, 0xfffffffe,
0x43b1e030)
0x003e8520 (oninit)rlogm_redo(0x6cf000, 0xfffffffe, 0xd1bf0f4, 0x132d2, 0x0,
0x43aba090)
0x00396ad4 (oninit)next_recvr(0x1d, 0x0, 0x68fd1c, 0x663534, 0x663524, 0x0)
0x004521e8 (oninit)prod_loop2(0x44085ec8, 0x436a0ac8, 0x4, 0x396704, 0x1,
0x440d3f38)
0x0045257c (oninit)producer_thread(0x6cf000, 0x61c188, 0xfffffffc, 0x43adde38,
0x43ad1890, 0x0)
0x004302d0 (oninit)startup (0x6dddbc, 0x7, 0x0, 0x42010960, 0x0, 0x42010920)
0x0042a124 (oninit)mt_poll_yield(0x0, 0x0, 0x0, 0x0, 0x0, 0x0)
0x00000000 (***nosymtab***)0x0
Thanks
Prabal
Even if you had support you no longer have support. IDS 7.31 went
completely out-of-support on September 31, 2009. You should upgrade, which
at this point will cost you a new license fee.
The most common cause of HDR hangs is slow communications between the
servers. Beyond that I have no idea. You could call IBM Tech Support and
get help from them on a time and materials basis.
Art
Art S. Kagel
Oninit (www.oninit.com)
IIUG Board of Directors (art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Oninit, the IIUG, nor any other organization
with which I am associated either explicitly or implicitly. Neither do
those opinions reflect those of other individuals affiliated with any entity
with which I am affiliated nor those of the entities themselves.
On Tue, Oct 13, 2009 at 6:11 AM, PRABAL DAS <d.prabal@gmail.com> wrote:
> Hi All,
>
> Our IDS v7.31 ud8, which is a HDR secondary pair failed suddenly and was
> found in a hung state. I had to recycle the engine to bring it up and now
> its
> running fine.
> This has occured second time within last 2 months.
>
> But I could not analyse the reason from af** files. onstat -l, onstat -d ,
> onstat -g sql etc does not give a proper reason why it was hung.>
> Does the first 'who' from the log indicates(?) that its a daemon thread.
> How
> can I analyse it further ?
> We donot have tech support.
>
> Can any one help?
>
> online.log
>
> 18:50:10 Rollforward of log record failed. iserrno = 124
> 18:50:10 Log Record: log = 78546, pos = d1c1558, type =
> OLDRSAM:ADDITEM(28),
> trans = 149
> 18:50:10 Log Record: log = 78546, pos = d1bf0f4, type =
> OLDRSAM:DELITEM(29),
> trans = 990
> 18:50:10 Assert Failed: No Exception Handler
> 18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
>
> 18:50:10 Who: Session(113, informix@abc, 0, 1129401080)
>
> Thread(255, xchg_1.4, 434eeb54, 13)
>
> File: mtex.c Line: 471
> 18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
> 18:50:10 Results: Exception Caught. Type: MT_EX_OS, Context: mem
> 18:50:10 Exception Recursion while handling: MT_EX_NONE, Context:
> 18:50:10 Assert Failed: No Exception Handler
> 18:50:10 Assert Failed: No Exception Handler
> 18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
> 18:50:10 Action: Action: %s
> 18:50:10 Who: Session(113, informix@abc, 0, 1192724196)
>
> Thread(265, xchg_1.14, 434f1d7c, 8)
>
> File: mtex.c Line: 471
> 18:50:10 Assert Failed: Memory free block header corruption detected in
> mt_shm_malloc_segid 1
> 18:50:10 Assert Failed: No Exception Handler
> 18:50:10 Results: Exception Caught. Type: MT_EX_OS, Context: mem
> 18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
> 18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
> 18:50:10 Action:
> 18:50:10 Who: Session(4628044, gtsrep@devrep.sd.avaya.com, 6540,
> 1129431704)
>
> Thread(4628093, sqlexec, 434f3b94, 1)
>
> File: mtex.c Line: 471
> 18:50:10 Results: Exception Caught. Type: MT_EX_OS, Context: ill
> 18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
> 18:50:10 Who: Session(113, informix@abc, 0, 1129401080)
>
> Thread(260, xchg_1.9, 434f0468, 7)
>
> File: mtex.c Line: 471
> 18:50:10 Results: Exception Caught. Type: MT_EX_OS, Context: mem
> 18:50:10 Action: Action: %s
> 18:50:11 Who: Session(113, informix@abc, 0, 1192724892)
>
> Thread(256, xchg_1.5, 434ef058, 9)
>
> File: mtshpool.c Line: 3006
> 18:50:11 Results: Unable to repair pool
> 18:50:11 Action: Please notify IBM Informix Technical Support.
> 18:50:11 invoke_alarm(): ALRMMALLOC failed: ALRMMALLOC(158)==0
> 18:50:11 listener-thread: err = -406: oserr = 62: errstr = : Memory
> allocation
> failed.
> 18:50:20 See Also: /analysis/dump/af.4e8cec2
> 18:55:12 VP Notify mechanism incomplete after 5 minutes. This can be due to
> slow network file access. Will try 12 more times
> 1
>
> Abbreviated output from AF* files
>
> onstat -u>
> 434ec838 ---P-R-*113 informix - 0 0 0 139 29151880
> 434ecd3c -----R-*113 informix - 0 0 0 0 0
> 434ed240 Y----RD*113 informix - 436a0a38 0 0 0 0
> 434ed744 -----RD*113 informix - 0 0 0 2393713 1508199
> 434edc48 Y----RD*113 informix - 436a1068 0 0 736291 715176
> 434ee14c Y----RD*113 informix - 436a1020 0 0 616100 673728
> 434ee650 Y----RD*113 informix - 436a0fd8 0 0 2079713 1557963
>
> /usr/informix_7.31.ud8/bin/onstat -g ses 113:
> *** WARNING: IBM Informix Dynamic Server is no longer running. ***
>
> *** WARNING: IBM Informix Dynamic Server is no longer running. ***
>
> IBM Informix Dynamic Server Version 7.31.UD8 -- Read-Only (Sec) -- Up 22> days
> 22:14:07 -- 2917680 Kbytes
>
> session #RSAM total used
> id user tty pid hostname threads memory memory
>
> *** WARNING: IBM Informix Dynamic Server is no longer running. ***
>
> /onstat -g sts:
>
> 255 40448 8306 20 4176 10 xchg_1.4
> 256 40448 11123 27 7080 17 xchg_1.5
>
> onstat -g stk all>
> Stack for thread: 255 xchg_1.4> base: 0x4407c000
> len: 40960
>
> pc: 0x0042e358
> tos: 0x44084fb0
> state: running
>
> vp: 13
>
> 0x0044e620 (oninit)afhandler(0x3, 0x6dddbc, 0x6ddbc0, 0x1, 0x4e7cec2, 0x1)
> 0x0044e094 (oninit)afcrash_interface(0x69adc0, 0x44085798, 0x6ce19c,
> 0x69add8,
> 0x1d7, 0x0)
> 0x004519c8 (oninit)mt_ex_throw_sig(0x65b400, 0x425c34dc, 0x0, 0x0, 0x0,
> 0x0)
> 0x00090d4c (oninit)afsig_segv(0x30303030, 0x30303020, 0x30303030,
> 0x32303230,
> 0x20202020, 0x20202020)
> 0x004474b8 (oninit)print_qhdr(0x0, 0x43b1e03c, 0xfffffffe, 0x7c,
> 0xfffffffe,
> 0x43b1e030)
> 0x003e8520 (oninit)rlogm_redo(0x6cf000, 0xfffffffe, 0xd1bf0f4, 0x132d2,
> 0x0,
> 0x43aba090)
> 0x00396ad4 (oninit)next_recvr(0x1d, 0x0, 0x68fd1c, 0x663534, 0x663524, 0x0)
> 0x004521e8 (oninit)prod_loop2(0x44085ec8, 0x436a0ac8, 0x4, 0x396704, 0x1,
> 0x440d3f38)
> 0x0045257c (oninit)producer_thread(0x6cf000, 0x61c188, 0xfffffffc,
> 0x43adde38,
> 0x43ad1890, 0x0)
> 0x004302d0 (oninit)startup (0x6dddbc, 0x7, 0x0, 0x42010960, 0x0,
> 0x42010920)
> 0x0042a124 (oninit)mt_poll_yield(0x0, 0x0, 0x0, 0x0, 0x0, 0x0)
> 0x00000000 (***nosymtab***)0x0
>
> Thanks
>
> Prabal
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--0015174bdcc8956d840475ced432
OK, I looked at the log entries below more carefully, iserr=124 indicates
that while the HDR secondary was rolling forward the logical log records
that it received from the primary, it encountered a logically impossible set
of records. The iserr message indicates ISAM level error -124 which is:
-124 ISAM error: no begin work yet.
The ISAM processor has been asked to mark the end of a transaction, but no
transaction has been started. For C-ISAM programs, review the program logic
to make sure that it calls isbegin before it calls iscommit or isrollback.
For SQL products, make sure that you execute BEGIN WORK before COMMIT WORK
or ROLLBACK WORK.
It looks like the engine found a COMMIT WORK log record for a transaction
for which it had not previously encountered a BEGIN WORK record. This can
be caused by an unreliable communication pipe between the servers or by a
bug in your version of IDS which, after all, is at least 5 years old.
Art
Art S. Kagel
Oninit (www.oninit.com)
IIUG Board of Directors (art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Oninit, the IIUG, nor any other organization
with which I am associated either explicitly or implicitly. Neither do
those opinions reflect those of other individuals affiliated with any entity
with which I am affiliated nor those of the entities themselves.
On Tue, Oct 13, 2009 at 6:11 AM, PRABAL DAS <d.prabal@gmail.com> wrote:
> Hi All,
>
> Our IDS v7.31 ud8, which is a HDR secondary pair failed suddenly and was
> found in a hung state. I had to recycle the engine to bring it up and now
> its
> running fine.
> This has occured second time within last 2 months.
>
> But I could not analyse the reason from af** files. onstat -l, onstat -d ,
> onstat -g sql etc does not give a proper reason why it was hung.>
> Does the first 'who' from the log indicates(?) that its a daemon thread.
> How
> can I analyse it further ?
> We donot have tech support.
>
> Can any one help?
>
> online.log
>
> 18:50:10 Rollforward of log record failed. iserrno = 124
> 18:50:10 Log Record: log = 78546, pos = d1c1558, type =
> OLDRSAM:ADDITEM(28),
> trans = 149
> 18:50:10 Log Record: log = 78546, pos = d1bf0f4, type =
> OLDRSAM:DELITEM(29),
> trans = 990
> 18:50:10 Assert Failed: No Exception Handler
> 18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
>
> 18:50:10 Who: Session(113, informix@abc, 0, 1129401080)
>
> Thread(255, xchg_1.4, 434eeb54, 13)
>
> File: mtex.c Line: 471
> 18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
> 18:50:10 Results: Exception Caught. Type: MT_EX_OS, Context: mem
> 18:50:10 Exception Recursion while handling: MT_EX_NONE, Context:
> 18:50:10 Assert Failed: No Exception Handler
> 18:50:10 Assert Failed: No Exception Handler
> 18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
> 18:50:10 Action: Action: %s
> 18:50:10 Who: Session(113, informix@abc, 0, 1192724196)
>
> Thread(265, xchg_1.14, 434f1d7c, 8)
>
> File: mtex.c Line: 471
> 18:50:10 Assert Failed: Memory free block header corruption detected in
> mt_shm_malloc_segid 1
> 18:50:10 Assert Failed: No Exception Handler
> 18:50:10 Results: Exception Caught. Type: MT_EX_OS, Context: mem
> 18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
> 18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
> 18:50:10 Action:
> 18:50:10 Who: Session(4628044, gtsrep@devrep.sd.avaya.com, 6540,
> 1129431704)
>
> Thread(4628093, sqlexec, 434f3b94, 1)
>
> File: mtex.c Line: 471
> 18:50:10 Results: Exception Caught. Type: MT_EX_OS, Context: ill
> 18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
> 18:50:10 Who: Session(113, informix@abc, 0, 1129401080)
>
> Thread(260, xchg_1.9, 434f0468, 7)
>
> File: mtex.c Line: 471
> 18:50:10 Results: Exception Caught. Type: MT_EX_OS, Context: mem
> 18:50:10 Action: Action: %s
> 18:50:11 Who: Session(113, informix@abc, 0, 1192724892)
>
> Thread(256, xchg_1.5, 434ef058, 9)
>
> File: mtshpool.c Line: 3006
> 18:50:11 Results: Unable to repair pool
> 18:50:11 Action: Please notify IBM Informix Technical Support.
> 18:50:11 invoke_alarm(): ALRMMALLOC failed: ALRMMALLOC(158)==0
> 18:50:11 listener-thread: err = -406: oserr = 62: errstr = : Memory
> allocation
> failed.
> 18:50:20 See Also: /analysis/dump/af.4e8cec2
> 18:55:12 VP Notify mechanism incomplete after 5 minutes. This can be due to
> slow network file access. Will try 12 more times
> 1
>
> Abbreviated output from AF* files
>
> onstat -u>
> 434ec838 ---P-R-*113 informix - 0 0 0 139 29151880
> 434ecd3c -----R-*113 informix - 0 0 0 0 0
> 434ed240 Y----RD*113 informix - 436a0a38 0 0 0 0
> 434ed744 -----RD*113 informix - 0 0 0 2393713 1508199
> 434edc48 Y----RD*113 informix - 436a1068 0 0 736291 715176
> 434ee14c Y----RD*113 informix - 436a1020 0 0 616100 673728
> 434ee650 Y----RD*113 informix - 436a0fd8 0 0 2079713 1557963
>
> /usr/informix_7.31.ud8/bin/onstat -g ses 113:
> *** WARNING: IBM Informix Dynamic Server is no longer running. ***
>
> *** WARNING: IBM Informix Dynamic Server is no longer running. ***
>
> IBM Informix Dynamic Server Version 7.31.UD8 -- Read-Only (Sec) -- Up 22> days
> 22:14:07 -- 2917680 Kbytes
>
> session #RSAM total used
> id user tty pid hostname threads memory memory
>
> *** WARNING: IBM Informix Dynamic Server is no longer running. ***
>
> /onstat -g sts:
>
> 255 40448 8306 20 4176 10 xchg_1.4
> 256 40448 11123 27 7080 17 xchg_1.5
>
> onstat -g stk all>
> Stack for thread: 255 xchg_1.4> base: 0x4407c000
> len: 40960
>
> pc: 0x0042e358
> tos: 0x44084fb0
> state: running
>
> vp: 13
>
> 0x0044e620 (oninit)afhandler(0x3, 0x6dddbc, 0x6ddbc0, 0x1, 0x4e7cec2, 0x1)
> 0x0044e094 (oninit)afcrash_interface(0x69adc0, 0x44085798, 0x6ce19c,
> 0x69add8,
> 0x1d7, 0x0)
> 0x004519c8 (oninit)mt_ex_throw_sig(0x65b400, 0x425c34dc, 0x0, 0x0, 0x0,
> 0x0)
> 0x00090d4c (oninit)afsig_segv(0x30303030, 0x30303020, 0x30303030,
> 0x32303230,
> 0x20202020, 0x20202020)
> 0x004474b8 (oninit)print_qhdr(0x0, 0x43b1e03c, 0xfffffffe, 0x7c,
> 0xfffffffe,
> 0x43b1e030)
> 0x003e8520 (oninit)rlogm_redo(0x6cf000, 0xfffffffe, 0xd1bf0f4, 0x132d2,
> 0x0,
> 0x43aba090)
> 0x00396ad4 (oninit)next_recvr(0x1d, 0x0, 0x68fd1c, 0x663534, 0x663524, 0x0)
> 0x004521e8 (oninit)prod_loop2(0x44085ec8, 0x436a0ac8, 0x4, 0x396704, 0x1,
> 0x440d3f38)
> 0x0045257c (oninit)producer_thread(0x6cf000, 0x61c188, 0xfffffffc,
> 0x43adde38,
> 0x43ad1890, 0x0)
> 0x004302d0 (oninit)startup (0x6dddbc, 0x7, 0x0, 0x42010960, 0x0,
> 0x42010920)
> 0x0042a124 (oninit)mt_poll_yield(0x0, 0x0, 0x0, 0x0, 0x0, 0x0)
> 0x00000000 (***nosymtab***)0x0
>
> Thanks
>
> Prabal
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--0023545bd494592b120475cef6db
Art, according to IBM Price List, there's still Trade Up for upgrading
v7 licences.
Hrvoje
Art Kagel wrote:
Even if you had support you no longer have support. IDS 7.31 went
completely out-of-support on September 31, 2009. You should upgrade, which
at this point will cost you a new license fee.
The most common cause of HDR hangs is slow communications between the
servers. Beyond that I have no idea. You could call IBM Tech Support and
get help from them on a time and materials basis.
Art
Art S. Kagel
Oninit ([1]www.oninit.com)
IIUG Board of Directors ([2]art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Oninit, the IIUG, nor any other organization
with which I am associated either explicitly or implicitly. Neither do
those opinions reflect those of other individuals affiliated with any entity
with which I am affiliated nor those of the entities themselves.
On Tue, Oct 13, 2009 at 6:11 AM, PRABAL DAS [3]<d.prabal@gmail.com> wrote:
Hi All,
Our IDS v7.31 ud8, which is a HDR secondary pair failed suddenly and was
found in a hung state. I had to recycle the engine to bring it up and now
its
running fine.
This has occured second time within last 2 months.
But I could not analyse the reason from af** files. onstat -l, onstat -d ,
onstat -g sql etc does not give a proper reason why it was hung.
Does the first 'who' from the log indicates(?) that its a daemon thread.
How
can I analyse it further ?
We donot have tech support.
Can any one help?
online.log
18:50:10 Rollforward of log record failed. iserrno = 124
18:50:10 Log Record: log = 78546, pos = d1c1558, type =
OLDRSAM:ADDITEM(28),
trans = 149
18:50:10 Log Record: log = 78546, pos = d1bf0f4, type =
OLDRSAM:DELITEM(29),
trans = 990
18:50:10 Assert Failed: No Exception Handler
18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
18:50:10 Who: Session(113, informix@abc, 0, 1129401080)
Thread(255, xchg_1.4, 434eeb54, 13)
File: mtex.c Line: 471
18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
18:50:10 Results: Exception Caught. Type: MT_EX_OS, Context: mem
18:50:10 Exception Recursion while handling: MT_EX_NONE, Context:
18:50:10 Assert Failed: No Exception Handler
18:50:10 Assert Failed: No Exception Handler
18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
18:50:10 Action: Action: %s
18:50:10 Who: Session(113, informix@abc, 0, 1192724196)
Thread(265, xchg_1.14, 434f1d7c, 8)
File: mtex.c Line: 471
18:50:10 Assert Failed: Memory free block header corruption detected in
mt_shm_malloc_segid 1
18:50:10 Assert Failed: No Exception Handler
18:50:10 Results: Exception Caught. Type: MT_EX_OS, Context: mem
18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
18:50:10 Action:
18:50:10 Who: Session(4628044, [4]gtsrep@devrep.sd.avaya.com, 6540,
1129431704)
Thread(4628093, sqlexec, 434f3b94, 1)
File: mtex.c Line: 471
18:50:10 Results: Exception Caught. Type: MT_EX_OS, Context: ill
18:50:10 IBM Informix Dynamic Server Version 7.31.UD8
18:50:10 Who: Session(113, informix@abc, 0, 1129401080)
Thread(260, xchg_1.9, 434f0468, 7)
File: mtex.c Line: 471
18:50:10 Results: Exception Caught. Type: MT_EX_OS, Context: mem
18:50:10 Action: Action: %s
18:50:11 Who: Session(113, informix@abc, 0, 1192724892)
Thread(256, xchg_1.5, 434ef058, 9)
File: mtshpool.c Line: 3006
18:50:11 Results: Unable to repair pool
18:50:11 Action: Please notify IBM Informix Technical Support.
18:50:11 invoke_alarm(): ALRMMALLOC failed: ALRMMALLOC(158)==0
18:50:11 listener-thread: err = -406: oserr = 62: errstr = : Memory
allocation
failed.
18:50:20 See Also: /analysis/dump/af.4e8cec2
18:55:12 VP Notify mechanism incomplete after 5 minutes. This can be due to
slow network file access. Will try 12 more times
1
Abbreviated output from AF* files
onstat -u
434ec838 ---P-R-*113 informix - 0 0 0 139 29151880
434ecd3c -----R-*113 informix - 0 0 0 0 0
434ed240 Y----RD*113 informix - 436a0a38 0 0 0 0
434ed744 -----RD*113 informix - 0 0 0 2393713 1508199
434edc48 Y----RD*113 informix - 436a1068 0 0 736291 715176
434ee14c Y----RD*113 informix - 436a1020 0 0 616100 673728
434ee650 Y----RD*113 informix - 436a0fd8 0 0 2079713 1557963
/usr/informix_7.31.ud8/bin/onstat -g ses 113:
*** WARNING: IBM Informix Dynamic Server is no longer running. ***
*** WARNING: IBM Informix Dynamic Server is no longer running. ***
IBM Informix Dynamic Server Version 7.31.UD8 -- Read-Only (Sec) -- Up 22
days
22:14:07 -- 2917680 Kbytes
session #RSAM total used
id user tty pid hostname threads memory memory
*** WARNING: IBM Informix Dynamic Server is no longer running. ***
/onstat -g sts:
255 40448 8306 20 4176 10 xchg_1.4
256 40448 11123 27 7080 17 xchg_1.5
onstat -g stk all
Stack for thread: 255 xchg_1.4
base: 0x4407c000
len: 40960
pc: 0x0042e358
tos: 0x44084fb0
state: running
vp: 13
0x0044e620 (oninit)afhandler(0x3, 0x6dddbc, 0x6ddbc0, 0x1, 0x4e7cec2, 0x1)
0x0044e094 (oninit)afcrash_interface(0x69adc0, 0x44085798, 0x6ce19c,
0x69add8,
0x1d7, 0x0)
0x004519c8 (oninit)mt_ex_throw_sig(0x65b400, 0x425c34dc, 0x0, 0x0, 0x0,
0x0)
0x00090d4c (oninit)afsig_segv(0x30303030, 0x30303020, 0x30303030,
0x32303230,
0x20202020, 0x20202020)
0x004474b8 (oninit)print_qhdr(0x0, 0x43b1e03c, 0xfffffffe, 0x7c,
0xfffffffe,
0x43b1e030)
0x003e8520 (oninit)rlogm_redo(0x6cf000, 0xfffffffe, 0xd1bf0f4, 0x132d2,
0x0,
0x43aba090)
0x00396ad4 (oninit)next_recvr(0x1d, 0x0, 0x68fd1c, 0x663534, 0x663524, 0x0)
0x004521e8 (oninit)prod_loop2(0x44085ec8, 0x436a0ac8, 0x4, 0x396704, 0x1,
0x440d3f38)
0x0045257c (oninit)producer_thread(0x6cf000, 0x61c188, 0xfffffffc,
0x43adde38,
0x43ad1890, 0x0)
0x004302d0 (oninit)startup (0x6dddbc, 0x7, 0x0, 0x42010960, 0x0,
0x42010920)
0x0042a124 (oninit)mt_poll_yield(0x0, 0x0, 0x0, 0x0, 0x0, 0x0)
0x00000000 (***nosymtab***)0x0
Thanks
Prabal
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.
--0015174bdcc8956d840475ced432
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.
References
1. http://www.oninit.com/
2. mailto:art@iiug.org
3. m